Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a brand new Dell Inspiron laptop running Windows 8. This has a mouse touchpad, not a touchscreen.

When we are using the laptop and are moving the mouse around, the Windows Charms sidebar will often pop up unexpectedly and interfere with our work. How can we stop the Windows Charms bar from popping up unexpectedly?

According to the Windows 8 documentation, the Charms bar should only display when I move the mouse pointer into the upper-right or lower-right corner of the screen, or when the user types 'Windows-C'. I assure you, our mouse is nowhere near the corners of the screen. Nor are we hitting 'Windows-C'. Usually I am moving the mouse pointer around in the middle of the screen, and suddenly for no obvious reason, the Windows Charm bar appears for no reason.

It is not something that I can replicate. I've tried various touch gestures and I have not been able to replicate this problem.

Update

I disabled particular mouse gestures as suggested below, and this worked for me. I updated the trackpad software, which re-enabled the mouse gestures and reinstated this obnoxious behavior. I had to disable it again.

Update

Thank you for this post. I finally discovered it was my starting position on the TrackPad that was causing the Charms to appear. There were no possible changes to the driver that would work. So I just need to start anywhere EXCEPT the very right side middle of the Track Pad.

share|improve this question
add comment

5 Answers

up vote 4 down vote accepted

Windows 8 now has touch gestures which are available on multi touch trackpads. If you slide your finger in from the right of the trackpad the charms menu will likely appear. It happens to me a lot as well. Another thing that happens with me is the start menu popping up. This is because if you open the charms menu via a gesture and then let go, the start menu will open as it is selected by default. Give it a try and see if it is what you are experiencing. If so you might just want to disable that gesture.

Have a look at your mouse settings in Control Panel. There will likely be a setting which modifies how the trackpad can be used. It is different for each driver so I can't give you very specific instructions.

This may be a solution for you: how do i turn off windows 8 gestures or on Superuser (a related question)

share|improve this answer
    
Thanks for the hint! The Charms Bar does not appear when I swipe from the righthand side of the trackpad, but I will look more into the mouse settings in the Control Panel. –  Stefan Lasiewski Jan 4 '13 at 22:34
add comment

Do you notice the mouse pointer juddering, drifting or otherwise misacting? It is possible the trackpad is generating spurious mouse movements that set off Windows' charms bar. If you have a trackpoint as well, try disabling the touchpad just to see if this problem disappears for the time being.

share|improve this answer
add comment

I found it in the track pad settings. I disabled the hotspot corners, but it was still popping up and it was so annoying.

In Control Panel > Mouse > Device settings > Settings, uncheck the box for Enable Edge Swipes.

share|improve this answer
add comment

Easiest thing to do is go to settings on right side bar, click on 'change PC settings' at bottom. There is one line that says, "when I swipe in from left, switch to my most recent app." Click button to turn this setting OFF. The bars may still pop up occasionally but at least they won't take you to another page.

share|improve this answer
add comment

Go to the mouse settings in control panel, select the EdgeAction(TM) tab then unselect "Right EdgeAction". That is what is most likely causing the issue.

share|improve this answer
add comment

protected by Community Jun 9 '13 at 1:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.