Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We recently purchased a Motorola SURFboard SB6121 modem and activated it with Comcast. After the technician activated the modem, she instructed me to connect a computer to it and try to go online. This failed, so she gave me a number for Motorola and told me to call back if I had any more problems. It turns out that the computer I was using (my mom's) never had Ethernet adapter drivers installed, go figure. How she manages to live without Ethernet drivers is an entirely different subject. I connected the modem to my computer and performed a power cycle. This worked, now I have internet (1 Gbps!). When I connected the modem to our router, an SMC SMCWBR15S-3N and performed a power cycle, the router never connected to the modem. I have reset my router to factory defaults, power cycled, and tried to connected again. I have tried setting a static IP for the router (the modem says it allocates IP addresses using DHCP, but it was worth a try). I have logged on to the modem's settings page, but there's really nothing there to change. I have tried everything I know but I still can't get internet through my modem. I have even tried a different router (old Linksys, I can get the model if you think that might help) to no avail. Please help me, preferably soon before my dad comes home and decides to fix it himself (he's largely computer illiterate, with the exception of excellent spreadsheet skills, so this would be a bad thing).

EDIT: Light flashes blue when connected successfully to computer. Light flashes amber when connected unsuccessfully to modem, but documentation states that this is an indication of a slower connection, not an error.

I am now going to try updating my router firmware. In addition, I will see if changing the power cycle order (router on first, then modem) will help.

share|improve this question
    
I'm a little bit confused as to what you are trying to achieve. Why don't you get the router to be the DHCP server instead of the modem? Simply use the modem as a gateway to the internet, but let the router handle the load. Is the modem being plugged into the router via wan? Is it lan cable to wan port? Please explain your setup. Sorry if I have simply misunderstood. –  Sam Jan 4 '13 at 23:26
    
The modem says that it uses DHCP, if that confuses you then, well, join the club. But yes, I am connecting the Ethernet cable from the modem to the WAN port of the router. –  Big Endian Jan 4 '13 at 23:28
    
Also, there appears to be no firmware upgrade for my router, so that isn't an option any more. –  Big Endian Jan 4 '13 at 23:29
    
Right, so you need to find the setting to disable DHCP on the modem and enable it on the router. Make sure the router and the modem have two different ip addresses and are on the same subnet ie ( 192.168.1.xxx) –  Sam Jan 4 '13 at 23:31
    
Also, the router won't be able to work with the modem unless you have setup the connection credentials under the setup tab. –  Sam Jan 4 '13 at 23:31

1 Answer 1

up vote 1 down vote accepted

Apparently, boot order is critical. I powered on my router first, waited 30 seconds, THEN powered on the modem. Now I have internet through my router again. I'm still curious as to why this might be, since all instructions I read say to do the reverse. Perhaps somebody has an answer to that, if not, I'll mark this as the answer as soon as the time limit passes.

share|improve this answer
    
You are correct that normally it would be the other way around. Not sure why this might be. –  Sam Jan 4 '13 at 23:36
    
You have something configured incorrectly and are managing to work around it somehow. It's hard to say exactly what. If the modem has a built in router, it should be connected to one of the router's LAN ports, not its WAN port. (And the DHCP server in the router should be disabled, since the modem is routing.) –  David Schwartz Jan 5 '13 at 0:59
    
There is no option to disable the DHCP server. If I plug the router into the LAN port, would I configure the router as a bridge? –  Big Endian Jan 5 '13 at 1:43
    
If you change what device is connected to the cable modem, you should reboot the cable modem, then connect the new device. This is because cable modems are normally (read: almost ALWAYS) set to only bridge for a single client. Once it sees one MAC address, it bridges for that one, and no others. Rebooting the modem clears its list of what MAC address(es) it'll bridge for. The more you know... Now, as for why you needed to have the router powered on first, I don't have a guess. Note this cable modem has no built-in gateway/router function, so don't plug it into the router's LAN port. –  snacky Jan 6 '13 at 15:54
    
I agree with what you've said entirely, having read much the same among various sources. Thanks for clarifying the business of the LAN port. Now that's all said and done what could be the purpose of the DHCP feature? I'm horribly confused! –  Big Endian Jan 7 '13 at 7:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.