Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lenovo ThinkPad T430s running with Arch Linux/Gnome 3.6 and I want to switch the left and right button of the trackpoint buttons (the upper ones). I can switch the left/right buttons of ALL mouses (trackpoint/touchpad/bluetooth mouses/usb mouses etc) with the gnome control center no problem, but not specifically for the trackpoint.

When I enter

xinput set-button-map 14 3 2 1 4 5 6 7

where 14 is the current xinput list device id of my trackpoint, everything is fine until I reboot, which also changes the device id somehow. It is possible to specify the device by name:

xinput set-button-map "TPPS/2 IBM TrackPoint" 3 2 1 4 5 6 7

but later I found out that this setting is lost after suspend. So I tried and created a x11 conf:

/etc/X11/xorg.conf.d/50-trackpoint.conf

with the content:

Section "InputClass"
    Identifier      "trackpoint"
    MatchProduct    "TPPS/2 IBM TrackPoint"
    MatchDevicePath "/dev/input/event*"
    Option  "ButtonMapping"  "3 2 1 4 5 6 7"
EndSection

but that is not working. It seems like this configuration is loaded before gnome and gnome changes everything back. So how do I do this?

share|improve this question
    
You could try adding the xinput command to your .bashrc file, not elegant but it might work. –  terdon Jan 5 '13 at 14:50
    
yes but what do I put in for the id (which changes on reboot, as I wrote) ? –  Eike Cochu Jan 5 '13 at 15:10
    
I added xinput set-button-map "TPPS/2 IBM TrackPoint" 3 2 1 4 5 6 7 to my gnome session. It does the trick, but it is ugly. As i learned the gnome settings daemon overrides xorg settings. –  Eike Cochu Jan 5 '13 at 18:18
    
edit: xinput setting is lost after suspend. –  Eike Cochu Jan 6 '13 at 0:31
add comment

1 Answer

up vote 0 down vote accepted

From http://askubuntu.com/questions/48955/how-can-i-configure-a-specific-usb-mouse-model-as-left-handed and http://ubuntuforums.org/printthread.php?t=1746468&pp=10&page=1 I gather that you might be missing

gsettings set org.gnome.settings-daemon.plugins.mouse active false

or (alternatively)

Then, once you run gconf-editor, from the GUI, navigate to

apps > gnome_settings_daemon > plugins > mouse

and uncheck the box for "active".

because that's

... not the end of the story, however, as Natty still uses gnome-settings-daemon to control mouse and keyboard settings. Usually, this is smart enough to get out of the way, but when it comes to mice, (specifically buttons) it will attempt to automatically ensure that your primary and secondary buttons are mapped to the system-wide left or right handed layout. In this particular case, we don't want that, so we need to turn this bit of functionality off.

Either of the above should work. Let me know if it doesn't. Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.