Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've poked around in settings but haven't found the right one.

This question poses almost the opposite problem.

I have my power management set to hibernate when I hit the power button. When it resumes from hibernate, the screen is not locked.

I have my screensaver set to not lock because I want to be able to avoid the password e.g. after reopening the lid when I haven't hibernated.

But I'd like to have a password set automatically when resuming from hibernate in case the laptop is stolen so that at least there's a slightly higher degree of difficulty to steal data.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You can use a program called gconf-editor to directly change various settings. It's kind of like Windows' registry editor. Press Alt+F2 to get the run dialog, and type gconf-editor and hit enter. Browse the tree to /apps/gnome-power-manager/lock/ and poke around at the settings there until you get the behavior you want. You'll probably want to uncheck use_screensaver_settings.

share|improve this answer
    
+1 for the helpful tips. Unfortunately those settings don't seem to work. –  bstpierre Oct 9 '09 at 4:21
    
They seem to have started working. (I had rebooted at least once before my previous comment, not sure what changed.) Thanks for your help. –  bstpierre Oct 13 '09 at 3:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.