Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new notebook with Windows 8. I need to boot a linux live distro from usb. However, when I access the boot menu which I expect to be like the following: enter image description here

in Windows 8, the entry "use a device" is missing enter link description here

(please do not care about red frames, these are only screenshots I have found on the web to show what appears on my monitor).

So, I have to edit UEFI settings, reboot the notebook, disable the UEFI boot and enable legacy boot in order to boot the live distro from usb.

When I have finished, I have to edit the bios settings again, disable legacy boot and re-enable UEFI boot in order to make the notebook being able to load windows 8 again.

Why am I missing the "Use a device" entry and how can I make it appearing?

share|improve this question
    
Does the entry show up if you boot with the USB drive inserted? Also, what make/model laptop is it? –  Karan Jan 5 '13 at 22:28
    
No. The "Use a device" entry is not shown. My notebook model is Acer E1 571. –  Toc Jan 6 '13 at 20:09
    
Can you edit your question and add screenshots of your UEFI settings? Is there nothing in there to allow you to boot from USB without disabling UEFI and reverting to legacy BIOS mode? –  Karan Jan 6 '13 at 21:39
    
I am unable to take a screenshot of my UEFI setting. Anyway yes, there is the option to switch from uefi to legacy boot. Simply I wonder why I cannot select "use a device" in the boot menu from inside windows 8. –  Toc Jan 7 '13 at 8:18

2 Answers 2

I had the same problem with my ASUS N56VJ-DH71 notebook. The solution I got from ASUS worked for me:

  • Enter the BIOS setup menu by pressing and holding F2 when powering on
  • Switch to "Boot" and set "Launch CSM" to Enabled
  • Switch to "Security" and set "Secure Boot Control" to Disabled
  • Press F10 to save and exit
  • Press and hold ESC to launch boot menu when the notebook restarts
    (or you can enter the PC setting menu in windows. You should see "use a device")
share|improve this answer
    
Sorry, I haven't the "Launch CSM" entry. And the "Secure boot" entry is blocked to "enabled". –  Toc Jan 11 '13 at 9:19

On the Acer E1-571 I found that after enabling the BIOS password, you are then allowed to disable secure boot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.