Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Normally Windows 8 redirects audio output to my headphone jack when a cable is plugged in. But as of a few days ago, it no longer does this. How can I restore this functionality?

My audio devices

Device Management

(no unrecognized devices)

share|improve this question
It could be a software/driver error, but how do you know for sure that the jack sensing mechanism is not broken? – Karan Jan 6 '13 at 22:08
Good question. Is there any way to check? – Pieter Jan 7 '13 at 9:03
Hmm, not sure. You could try a Linux/WinPE LiveCD/USB, but I don't think advanced soundcard-specific features will be enabled in such an environment that uses generic drivers. You can try deleting all the audio devices from Device Manager and reinstalling the latest drivers, but if that doesn't fix it I guess only an OS reinstall would confirm whether it's a hardware issue or not. – Karan Jan 7 '13 at 20:50
Isn't there a built-in Windows diagnostic that says "Headphones are plugged in" or "Headphones aren't plugged in"? – Pieter Jan 8 '13 at 10:42
Not that I know of, but most soundcards (even on-board ones) come with software that helps you run diagnostics, shows a visual display of which jacks have devices plugged in etc. – Karan Jan 8 '13 at 16:32

Right click on your headphones and select "Set as Default Device"

share|improve this answer
Pretty much that. I've had to do that in windows 7 as well – Journeyman Geek May 20 '13 at 13:50
Does this reinstate the auto-switching behavior? I can no longer reproduce the problem so I can't verify your proposed solution. I think it may have been driver-related in my case, because I'm currently using the default Windows 8 driver instead of the one that the manufacturer supplied. – Pieter May 20 '13 at 15:46

You can't select it as the default device because it doesn't consider it to be plugged in.

share|improve this answer
Assuming the poster has the headphones plugged in, how else would this solve it? This would be better as a comment – Canadian Luke Oct 14 '13 at 4:20

I found a solution if you use windows 8 and you plug in your earphones/headphones and you cannot hear anything, but the speakers work. Go to the loud speaker icon at the bottom right and right click it.then click sound manager. go to the advanced tab then click jack information. click the picture of the audio jack hole and then click headphones. then click ok. Your sound should work now through your earphones/headphones.

share|improve this answer

If you are using Windows 8 in HP Probook 14 then just go to Control Panel and search Sound. Select Change sound card settings and select the Headphones and set as default.

So when you plugin your earphones it will automatically switch to the earphone or any output devices through the 3.5 jack. Worked for me and when you remove phones it will pick internal by default.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.