Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two connections at different places, provided by two different ISPs. Both are using PPPoE to connect.

When using Windows, I configure them in the same manner, except username and password of course. Both are working.

While in linux (debian), using Roaring Penguin's RP-PPPoE, one is working and the other is not. I can dial up, but can't ping anywhere.

And, there was a time I have a Windows box connected to the linux-not-working network, then connect my linux through VPN to it, then pppoe-start, it magically worked.

1) Is the provider blocking linux?
2) Why dialing up through VPN is working?
3) Is there a way I can work around, using only my linux? Say fake to be a Windows on the network?

share|improve this question
    
Are you saying that both the ISP's block Linux ? –  HackToHell Jan 6 '13 at 17:14
    
@HackToHell - The OP (@Theo) says Windows can connect to both ISP's, but Linux can only connect to one of the ISP's, and is asking if it is possible that the one ISP is blocking connections from Linux machines. –  Kevin Fegan Jan 6 '13 at 19:18

2 Answers 2

up vote 0 down vote accepted

Solution from my friend:

  1. Install Windows on a virtual machine, say VirtualBox.
  2. Set up two connections, one is bridged to eth0, another host-only. The bridged one is used to dial up PPPoE, the host-only one is to share it's connection with Linux.
  3. Dial up in Windows.
  4. Connect Linux through the virtual machine's shared connection.

As for whether the ISP is blocking Link, I have no idea.

share|improve this answer

Have you tried a normal PPPOE modem ? and can you list the model because 99.9% of Home ADSL routers run some form of linux so it is unlikely that their would some sort of "Blocking".

It could more likely be a misconfiguration with your PPPOE client. off the top of my head you should check the MTU value (like the maximum packet size allow to go down the line) make sure it is no more that 1492 or lower and a multiple of 8 (google suggestions)

This could cause even pings to fail as every packet would become malformed. Futhermore it could have worked through your "VPN or lan" as the programs that transform the packets may bring them under the maximum or put fragment flags on the packets.

Yes you can change the hello of the IP packet header but it is not really an answer to your problem.

share|improve this answer
    
Modem? I don't need any modem to connect. As for the MTU value, I found it commented out in /etc/ppp/options, I tried mtu=1200 but doesn't work. –  TheoYou Jan 11 '13 at 15:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.