Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here is my current situation along with the events that followed up to it:

  • I installed Ubuntu 12.10 amd64 to my Lenovo Ideapad S300 by booting to a USB Drive that I prepared with Unetbootin (v583). The USB drive appeared in my BIOS as something along the lines of 'UEFI USB PNY 8 GB'. I went in and created one partition for / and one for swap. (I know, it was a very basic install; I'm new to this sort of thing so I didn't bother with /boot or /home etc.)
  • I want to remove Ubuntu 12.10 and install Ubuntu 12.04 i386 (32-bit version). Unfortunately, I can't because I can no longer boot to any USB device (or SD card for that matter). When I press the Lenovo OneKey button to get to the boot menu, the device simply does not show up. The same thing happens if I go into my BIOS boot order. All I see is the Windows Boot Manager, two instances of the Ubuntu boot manager (both lead to GRUB2), and two boot options that have something to do with ipv4 and ipv6 network boot, or something along those lines (irrelevant).
  • I have tried just about every possible combination, experimenting with multiple USB drives and SD cards, Ubuntu 12.04 and 12.10 (i386 and amd64 versions), using the Windows built-in formatting tool and the legacy HP formatting utility, using Unetbootin and LiLi USB Creator ... but no luck.
  • I have tried these USBs with another computer (ASUS G75VW) and they work just fine; I can boot from them into Linux with no problem.

Any ideas on what do do at this point? I really need to remove Ubuntu 12.10, and I would certainly like to be able to boot from USB drives in the future with my Ideapad.

share|improve this question
    
You mention two instances of Grub, are they two instances of the same grub or is one from the USB? Forgive me if I read your post incorrectly and misunderstood that piece. –  nerdwaller Jan 6 '13 at 21:00
    
Both boot options are named "Ubuntu (WDC WD5000LPVT-08G33T1)", except one has a lowercase U as in "ubuntu" and one has an uppercase U as in "Ubuntu". Interestingly, the uppercase one seems to just boot straight into Windows 8 regardless of whether the LiveUSB is in. The lowercase works properly, booting normally into Grub, again regardless of whether the LiveUSB is in. I'm guessing from this that neither of these boot options are coming from the USB, and the one with the uppercase U is garbage/corrupt. –  Intredasting Jan 6 '13 at 22:43
add comment

2 Answers 2

up vote 0 down vote accepted

I finally fixed the problem. I had to change the boot mode in my BIOS from [UEFI] to [Legacy Support]. I'm not sure why I was able to boot to the USB drive before installing Ubuntu without having that setting enabled, but alas; I'm not complaining.

share|improve this answer
add comment

Your issue is the way it should behave :

in UEFI mode, you can only use a 64 Bits linux OS because the EFI loader is 64 bits only.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.