Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

somehow I downloaded and installed spyware or malware. I do not know. I know that if I write somethin in field where you put as a website link I get web engine results but not by google but fastaddressbar.. It is part of websearch toolbar. Most of them was blocked and added to quarantine by my antivirus comodo however I still do not know how restore fast search in firefox to get results from google. Please help :(

enter image description here

share|improve this question

5 Answers 5

In the top bar, type about:config. In the search bar on the page, type browser.search.defaultenginename. Double-click the value that appears, and enter Google in the window that appears. Click "OK" and restart Firefox. Your search engine is now Google!

share|improve this answer
    
yes but after restart i have again this malware :/ no mather what I set there or just click reset value –  deadfish Jan 6 '13 at 21:54

Go to Programs and Features in the Control Panel and look for an entry there. Also, go to Firefox > Add-ons > Extensions and remove it if it is installed there. Source credit: http://www.pcrisk.com/removal-guides/6953-remove-fast-address-bar

share|improve this answer
    
yes but this is just a homepage, i dont want also see this malware site when i search any text inputting this into field with link. I made an arrow what I was talking about –  deadfish Jan 6 '13 at 21:26
    
Updated answer and included a link that may help. –  K.A Jan 6 '13 at 22:06

Uninstall it from Add/Remove Programs if it shows up there, then run Malwarebytes Anti-Malware Free to clean your PC, and finally if it's still there, reset Firefox (be sure to read that entire page before doing it).

share|improve this answer
    
in add/remove programs was nothing which could be connected with this program, i tried spbybot but he doesn't help :/ I will try this Anit-Malware... –  deadfish Jan 7 '13 at 8:13

You can try this, it was useful for me: How to reset the address bar so it would work as a Google Search bar again? | Firefox Support Forum

When you enter a search term in the Firefox location bar and press Enter, Firefox will per default do a "I'm feeling lucky" Google search and redirect you to the first result that matches your search term. This behaviour can be changed by a number of add-ons. If you'd like to restore the previous default behaviour, please follow these steps:

  • Enter about:config in the Firefox location bar and press Enter.
  • You should see a warning that making changes to the Firefox configuration can be potentially harmful to Firefox's integrity. Click the I'll be careful, I promise button to continue.
  • In the Search box at the top, enter keyword as the search term. You should see a few remaining items, one of these is keyword.URL. It should be bold.
  • Right-click on the keyword.URL setting and select Reset from the dropdown menu.
share|improve this answer
    
yes, but as I said few posts ago that after restart I have again the same settings with that ugly malware fastadressbar –  deadfish Jan 10 '13 at 22:08

I suggest you use a program called ADw Cleaner. This program is very effective at removing annoying toolbars. I have used it in the past to get rid of the annoying Babylon toolbar amongst other addons, which it did, and also in very little time.

Click on Download Now @BleepingComputer at the following web address:

http://www.bleepingcomputer.com/download/adwcleaner/

I'm positive it will solve the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.