Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install VS2010 on my new Windows 8 machine. This is an install from an MSDN subscription and it installed fine on my Windows 7 machine. But when I try on the new machine, I have to accept the EULA, and then it shows a messages that says:

You have entered an invalid product key for this product. The 25 character product key may be found on the media case or obtained online at: [some Microsoft page]

But this is really weird because there's no place to enter the product key, and it never asked for a key on Windows 7, which installed and worked fine. So I think it may be a Windows 8 thing.

Anyone know what's going on here?

share|improve this question
up vote 0 down vote accepted

Here is a solution I found online for your problem:

  1. Find the setup\setup.sdb file in the Disk or Image.
  2. Open this setup.sdb file in Notepad like program.
  3. Find the tag [Product Key] BD9TPWJD9XBWX4KQPWVY4GW9G
  4. Replace this product key by new key either from any source or from

http://www.microsoft.com/visualstudio/en-us/download

Under "REGISTER TO EXTEND YOUR TRIAL"

People say it helped.
Good Luck

share|improve this answer
    
This worked to let me enter my product code, and then I was able to enter the correct code and install. Thanks! – Joshua Frank Jan 6 '13 at 22:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .