Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I made it so that I don't need to enter a password to login to my computer. My Microsoft account is the only one used on it, and I live alone, so entering my password every time I want to turn the computer on is a pain to not much of a use.

However, when I upgraded to Windows 8, I was really looking forward to the new lock screen. Seeing upcoming events, new emails and such, obvious and huge on the screen when I get back after being away from the computer for a while, to me, is pretty awesome, since I tend to forget things. A good automatic and constant reminder. But I don't even understand how to make it appear again. Do I -absolutely- need a password? Can I, say, make a picture password and define the whole damned screen as the point to click to unlock it, with only one or two clicks required?

I realise the purpose of a lock screen is to lock - if there's no password, it's not locked. But I was hoping that maybe there's a way to have it there, only to disappear when I click, a bit like my Android phone has a lock screen which only needs a swipe from my finger to go away.

share|improve this question
    
I found a registry hack called ScreenSaverGracePeriod, but that only works for ScreenSaver. My idea, there may be a similar hack for LockScreen. –  Guy Thomas Jan 6 '13 at 22:48
    
Doesn't 'Windows Key + L' work for this? –  Techie Joe Jul 10 '13 at 21:32
    
@TechnieJoe This requires me to enter my password, on top of requiring an action. I'd want it to be automatic. –  Ariane Jul 10 '13 at 23:49

6 Answers 6

Bring up Search from the Charms bar. Search for "Run" and open it. Type in control userpasswords2. Go to the Advanced tab. Select, at the bottom, "Require users to press Ctrl+Alt+Delete.

This will force a lock screen so you have to press the three finger salute (control alt delete), but after that, when it asks for a password, just hit enter.

share|improve this answer
    
I have just tried what you said. I let my computer alone until the screen went black, and then I moved the mouse. I was right back to this page. Nothing different happened. Did I miss something? –  Ariane Jan 6 '13 at 23:54
    
No, I don't think you missed anything. I recall using that trick in a previous version of Windows. Maybe if you also set up a password that is just blank it will take effect? –  K.A Jan 6 '13 at 23:59
    
Maybe it requires a screensaver or something? Right now, what makes the screen go black is the power management option to "turn the screen off". –  Ariane Jan 7 '13 at 1:31
    
Aha! That is different. Try putting the computer to sleep (Swipe in, Settings, Power, Sleep) and then wake it up. You should get the lock screen then. –  K.A Jan 7 '13 at 2:28
    
Sleep... That's inconvenient. :c I never let my computer go to sleep, because when it does, it disconnects the Internet, and I can't receive Skype messages anymore. And since Skype doesn't manage offline messaging (if a contact messages me while I'm offline and logs off before I come back, I won't see it before we're both online at the same time again), it sucks really bad. Can it work with a screensaver or something? I can't find the lock screen settings anywhere. –  Ariane Jan 7 '13 at 3:07

This could be a pretty good solution for you.

First Step: Screensaver settings. Right click desktop, personalise, screensaver. Check the box that says "On resume, display login screen". Hit apply then ok.

Second Step: Making sure we are automatically logged in. Windows + R to bring up run, type netplwiz. With your user name highlighted untick the box that says "Users must enter a user name and password to use this computer". Hit apply then ok.

Third Step: Creating a picture password. Bottom right corner, settings, users, change picture password. Find a picture you like, create the three gestures, confirm the three gestures and then click finish.

Now restart your computer. You will be automatically logged in and when your screensaver is now interrupted, you will resume at the lock screen with a gesture based unlock.

share|improve this answer
    
But that requires a gesture... Isn,t there a way to do it with just clicking or something ? Besides, from this example, it doesn't even show the lock screen on the picture password page. blogs.msdn.com/cfs-filesystemfile.ashx/__key/… –  Ariane Jan 15 '13 at 18:16

Go to the personalize option in the desktop right click menu and open the screen save settings. Here set a screen saver and select the box that says "On resume, display login screen"

Now when you resume your computer from the screen saver, you'll be greeted by the lock screen. A simple click, keypress, swype, etc. brings you back to where you left off.

Alternatively, you can just press Win+L when you leave your computer.

If you don't want a screen saver, choose "Blank" as your screen saver rather than "(None)", as from my testing, the lock screen will not show when you have it set to None.

share|improve this answer
    
It doesn't work. I set it to 1 minute and wait, and when the "blank" screensaver appears, I shake the mouse. I'm back to the desktop. –  Ariane Jan 20 '13 at 7:12
    
Update: I was back to the desktop because I shook the mouse too fast. Waiting more brings me to a "lock screen". But not the one with useful information. Basically just my user picture and username. And I DID need to enter a password. And Windows+L forces me to enter a password as well (though this one does show the useful lock screen). –  Ariane Jan 20 '13 at 7:18
    
Another update: Adding the Ctrl-Alt-Delete setting DOES show the useful lock screen, so we're on the right way. But it still asks for password afterwards. Besides, pressing Ctrl-Alt-Delete is inconvenient... :/ –  Ariane Jan 20 '13 at 7:29
1  
I thought you weren't using a password. I don't think there's any way for you to have a password on your account while not needing one at the lock screen. And are there different lock screens? I've only seen one. –  ABarney Jan 20 '13 at 20:01
    
When you use an online Microsoft account, you HAVE to have a password. Else it'd be like your Hotmail account doesn't have a password. However I've made it so that it's not necessary for login. But if I bring up the lock screen, it asks me for it. And well, there aren't two lock screens. There's the lock screen, with the time and calendar notifications, and then there's the login screen, blank except for the login. –  Ariane Jan 20 '13 at 21:11

All I did was this go to screen saver and click "none". Next to it you will see a box titled "On resume, display logon screen". Untick that box. That solved my problem; hope it helps you, too. All that will happen then your screen will go blank like normal. Move mouse back again.

share|improve this answer
    
This doesn't do anything what I want. It asks for my password. –  Ariane Mar 24 '13 at 19:30

I know this is an old thread but it still may help some people.

The solution is to switch from using your Microsoft online profile to a local one.

Swipe in from the right, go to change PC settings, go to accounts, then where you see your Microsoft email account, click disconnect. This will prompt you to create a local PC profile. After you enter your name, just hit enter in the password field. Now whenever you swipe up on the lock screen, it will go right to start. This works well if you're like me and don't use your Microsoft live account for anything.

share|improve this answer
    
I guess this can work. Though I particularly dislike the idea of making another, local, account just for a detail like that. –  Ariane Oct 20 '13 at 16:47

The gesture based unlock I have found to be most convenient. Instead of drawing 3 gestures triple clicking a spot of your choice works just as well. Quick and simple.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.