Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Windows 7 and for some weeks I can't use Windows commands (e.g. taskkill) anymore but Linux commands (e.g. ls, kill, ps,...) instead. The problem seems to be that it is not using my PATH environment variable anymore because it contains all necessary paths like "C:\Windows\system32" but it still says "command not found" for all programs contained in those folders.

It must have something to do with my installed Cygwin which I did several months ago and which I'm updating regularly. Also I've installed the git bash, in which I can use Linux commands, too...could have something to do with it. It looks like Windows got some kind of infected with Linux and is now sick, to describe it in a funny way

I don't know what it was exactly that I did that this all happened, can anyone help?

share|improve this question

migrated from Jan 6 '13 at 23:40

This question came from our site for professional and enthusiast programmers.

Why am I getting downvoted? I seriously have no idea how to set my cmd back to "normal". – Michel Michael Meyer Jan 6 '13 at 23:11
Type Path at the command prompt. What is the output? – Aluísio A. S. G. Jan 7 '13 at 0:00
Git-Bash has an option to use linux commands only in Git shell (the one that comes with it). You could try to remove Git-bash and reinstall with that option enabled (or disabled? I forgot what the option actually reads). – hayavuk Jan 7 '13 at 0:37
Are you sure you're running the Windows command shell and not bash or another Cygwin shell? – Harry Johnston Jan 7 '13 at 2:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.