Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I followed these instructions for esxi 5.1 to enable copy paste from the host config. (search for "To enable this option for all the virtual machines in the ESX/ESXi host:") http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1026437

But copy and paste doesn't work for new VMs or existing VMs.

Did I do something wrong somewhere?

I've rebooted VMs and even rebooted host. I can confirm that if I do a per VM configuration, it works. Just not a central host config.

Here is a screenshot of my /etc/vmware/config file

config screenshot

share|improve this question

3 Answers 3

You must add:

isolation.tools.copy.disable = "FALSE"
isolation.tools.paste.disable = "FALSE"

to virtual machine configuration file (*.vmx). In my case this file is placed in:

/vmfs/volumes/datastore1/MyVmMachine/MyVmMachine.vmx

After editing this file and add two lines provided above copy paste works perfectly!

share|improve this answer
1  
this question relates to enabling from the host config, not each individual VM comfig. –  w-- Jun 27 '13 at 20:54

I just got copy/paste working on ESX 5.1

Two ways to affect copy/paste

  • Each VM you can add the "isolation.tools.*" variables
  • OR you can add Copy/Paste to all VMs by SSH'ing into ESX and edit /etc/vmware/config

I think your issue may be that you need to Power-Off and back on the machine ... not just an OS reboot, actually from Vsphere. Here's VMware's KB quote:

The Copy and Paste options are only enabled when the virtual machines restart or resume the next time or shutdown and power-on the virtual machine for changes to take effect. This must be done on the virtual machine side, not the guest OS side.

Secondly, make sure VMware tools are installed in your VMs

This is described here

share|improve this answer

I noticed you don't have the vmx.fullpath property in your config file and you have blank line. Try changing your config file to match this one: http://www.ryanbelanger.com/vmware-esxi-copy-paste/

Then reboot a VM and test the settings.

share|improve this answer
    
Thx @JamesBarnett, haven't had a chance to try this yet. What is the vmx.fullpath property supposed to do? I can't seem to turn up documentation on this? –  w-- Jan 10 '13 at 6:40
    
unfortunately, this did not work. =( –  w-- Jan 12 '13 at 6:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.