Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm attempting to setup a public squid3 server but I'm running into roadblocks at every turn.

This server I've installed squid on has a public IP address and I'd like to use it as a proxy server wherever I am. I'm attempting to just get the basic open proxy server open and then from there lock it down, but I can't even get that far.

I'm using Ubuntu 11.04 and I've installed squid3 via apt-get.

Here is my config file below without the comments (yes I was over zealous with the allows):

acl allIP src all
acl alldstIP dst all
acl manager proto cache_object
acl localhost src 127.0.0.1/32 ::1
acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1
acl SSL_ports port 443
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443         # https
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl CONNECT method CONNECT
http_access allow all
http_access allow allIP
http_access allow alldstIP
http_access allow localhost
http_access allow to_localhost
http_port 3128
hierarchy_stoplist cgi-bin ?
cache_dir ufs /var/spool/squid3 100 16 256
coredump_dir /var/spool/squid3
refresh_pattern ^ftp:           1440    20%     10080
refresh_pattern ^gopher:        1440    0%      1440
refresh_pattern -i (/cgi-bin/|\?) 0     0%      0
refresh_pattern .               0       20%     4320
cache_effective_user MYUSER
cache_effective_group root

Extra information: top tells me squid3 is running, but I can't telnet to my server on the proxy port (another question said that was a good debugging step)

share|improve this question
up vote 0 down vote accepted

After messing around further and testing on another computer, it seems that my Windows 7 installation just did not want to connect to ANY proxy servers except when I set it up in Firefox. This config worked on another machine as well.

NOTE: The config above will open up everything and allow others to use your server as a proxy. Thinking it wasn't working I left my settings like this only to get a email from my hosting provider warning me of suspicious activity.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .