Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My desktop has a non-OS drive D: 2000MB WD Green (model WD20EARS-00MVWB0, firmware version 51.0AB51).

After the computer boots / wakes from sleep, in the first time I access D: drive, the program which accesses it (Explorer / etc.) locks up for several seconds. If the computer wakes up and there was some program accessing the drive (say, an Explorer window open), then the log-on screen will lockup for several seconds.

I presume the drive's firmware deliberately spins-up only on access, and I want to disable this behavior. I've found an Anandtech post that mentions WD's WDIDLE3.exe utility. However, this utility lists several 750-1000MB drive, with a stern warning not to use on any other drives. There's also idle3-tools, but that's only for Linux.

How can I disable this behavior through Windows?

OS: Windows 8 64-bit, though it happened with Windows XP as well.

share|improve this question
add comment

4 Answers

up vote 4 down vote accepted

Read through this WD forum thread and this WD Knowledge Base article carefully. The WD20EARS Green drive is supported by the WDIdle3 utility. I have used it myself from an MS-DOS/FreeDOS USB stick to change the idle timer, and I believe WDIDLE3 /D should disable the timer completely (or at least set it to its max supported value; check WDIDLE3 /? for all supported options).

Note: Although the operation should be safe (I ran it on a drive that was almost full), it's always a good idea to have a backup of your data before attempting something like this.

share|improve this answer
    
Thanks, I'll try that after I setup a backup (at least of irreplaceable material). –  Jonathan Jan 8 '13 at 18:59
add comment

IIRC the "green" range can't have these features tweaked any more, thought the "black" (and perhaps also the "blue") ranges do - they are pretty much locked to the low-power settings.

Though this is 2nd-hand information as I bought different drives instead having found people discussing similar issues.

share|improve this answer
    
I can confirm that your second-hand info. is incorrect. –  Karan Jan 7 '13 at 23:43
    
Fair enough. At the time I was looking I got the impression that some Green drives supported the switching of those options bits (along with others like "RAID-quick-fail") but most didn't and you could not guarantee which revision of the units you were getting. +1 for providing a detailed answer. –  David Spillett Jan 8 '13 at 17:52
add comment

I had the same problem when backup my Linux servers to WD green USB drives. Simple way to do this is to ping the drive every minute or so. In Linux I do this via crontab, in windows you can do this by creating a little bat script and running it in Scheduled Tasks.

SpinDrive.bat

D: dir

#

Create a scheduled tax to run this every minute or so.

share|improve this answer
    
Thanks for the workaround. I'm more interested in the post boot/wake-up behavior, for which a scheduled task will no help much. –  Jonathan Jan 7 '13 at 20:23
    
You could hook something to the wake-up phase that read something relatively random (to reduce the chance of it being in cache) from the drive (or wrote a small temporary file to the drive and forced a flush-to-disk). I know the Linux power management tools in most distros allow this relatively easily so I assume Windows has a way too. That would spin up the drive as fast as anything could after a wake from sleep or hibernate. –  David Spillett Jan 7 '13 at 22:11
add comment

I use QuietHDD. Set APM to 255 and AAM to 254 (these are max settings). It will hopefully ensure that your drive won't spin down.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.