Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Windows XP the system info reports a CPU frequency of 848 mhz. Using cat /proc/cpuinfo gives me a CPU frequency of only 700 mhz and lshw says that the capability is 1ghz. Is there a solution for this?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Edit: I see you're on Xubuntu. The scaling applet in XFCE4 is in the "xfce4-cpufreq-plugin" package; make sure it's installed.

Looks like that computer uses a PIII(-M?) 1GHz? That should be supported by one of the speedstep drivers in this list:

The Linux kernel CPUfreq subsystem can only work on a system if the hardware supports CPU frequency scaling and a device driver exists.

  • Intel SpeedStep using the SMI BIOS interface (speedstep-smi)
  • Intel SpeedStep on ICH-based chipsets (speedstep-ich)
  • Intel Enhanced SpeedStep (acpi-cpufreq and speedstep-centrino)

Here's a tutorial covering CPU frequency scaling in Linux.

There's a bug open on Ubuntu Jaunty that complains about CPU scaling not functioning on a similar CPU to yours. The upshot is that the kernel may be deciding that frequency scaling may not be useful for your processor. If you're running into this bug, disabling frequency scaling entirely may help you get it running faster.

If nothing else has worked yet, we'll need more information. First let's try to make sure your kernel is using the right driver for your CPU.

Please update your question with the output from these commands:

$ dmesg | grep cpufreq

$ cpufreq-info --driver
$ cpufreq-info --hwlimits
$ cpufreq-info -m -freq

If you don't have the cpufrequtils package installed, install it ("sudo apt-get install cpufrequtils").

share|improve this answer
    
Interesting, after installing cpufrequtils and xfce4-cpufreq-plugin the speed went up to 850 MHZ, I think it due to cpufrequtils. The cpufreq-info command doesn't give me any useful output, most commands it just quietly ignores. –  Georg Schölly Oct 8 '09 at 22:17
    
Even stranger, after I've removed both packages it still says 850 mhz after rebooting. –  Georg Schölly Oct 8 '09 at 22:17
    
it may have left a setting behind somewhere in /etc. did you try running the cpufreq-info command as sudo? i'm not sure if that's needed or not. –  quack quixote Oct 8 '09 at 22:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.