Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using facter to get some information for some bash scripts. When I run facter by itself, it shows me items such as serialnumber and productname. But when I run facter serialnumber or facter productname, I get nothing. Any ideas?

myhost:/tmp # facter
facterversion => 1.5.2
operatingsystem => SLES
productname => IBM System x3200 M2 -[4367AC1]-
puppetversion => 2.6.12
rubyversion => 1.8.7
serialnumber => KQABCDE
virtual => physical

myhost:/tmp # facter facterversion
myhost:/tmp # facter rubyversion
myhost:/tmp # facter operatingsystem
myhost:/tmp # facter productname
myhost:/tmp # facter puppetversion
myhost:/tmp # facter serialnumber
myhost:/tmp # facter virtual
share|improve this question
up vote 2 down vote accepted

It's a bug in the 1.5.x branch of Facter. I can't recall the exact version it was fixed in, but a more recent 1.6.x version will fix the issue.

share|improve this answer
I figured it might be a bug. Thanks. – Ed Manet Jan 8 '13 at 16:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.