Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a site hosted from my Raspberry Pi, and recently I've ran into this problem:

When I view the site on the local network, the site looks great. Everything loads, all the CSS etcetera.

However, whenever I view it outside the local network, the index page loads, but none of the other pages load and the site is all plain text.

What could the problem be? According to Chrome there is no error message and it just says "failed".

The site is running WordPress.

Site URL: http://northantrim.redirectme.net (only until I get this issue solved)

How the site should look: http://i.imgur.com/4UJNW.png

Current permissions (set to 777 in hope of resolving):

pi@raspberrypi /var/www $ ls -l -a -h
total 5.4M
drwxrwxrwx  6 www-data root     4.0K Jan  7 00:16 .
drwxr-xr-x 13 root     root     4.0K Jan  6 22:09 ..
-rwxrwxrwx  1 pi       root      395 Jan  8  2012 index.php
-rwxrwxrwx  1 pi       root     5.2M Jan  6 22:50 latest.zip
-rwxrwxrwx  1 pi       root      20K May  6  2012 license.txt
drwxrwxrwx  6 pi       pi       4.0K Jan  6 22:20 linfo
lrwxrwxrwx  1 pi       root       21 Jan  6 22:05 phpmyadmin -> /usr/share/phpmyadmin
-rwxrwxrwx  1 pi       pi        16K Jan  7 00:16 privacy_policy.html
-rwxrwxrwx  1 pi       root     9.0K Nov 30 00:57 readme.html
-rwxrwxrwx  1 pi       root     4.6K Nov 17 15:11 wp-activate.php
drwxrwxrwx  9 pi       root     4.0K Dec 11 16:20 wp-admin
-rwxrwxrwx  1 pi       root      271 Jan  8  2012 wp-blog-header.php
-rwxrwxrwx  1 pi       root     3.5K Apr 10  2012 wp-comments-post.php
-rwxrwxrwx  1 pi       www-data 3.4K Jan  6 22:56 wp-config.php
-rwxrwxrwx  1 pi       root     3.2K Nov  1  2010 wp-config-sample.php
drwxrwxrwx  6 pi       root     4.0K Jan  7 00:17 wp-content
-rwxrwxrwx  1 pi       root     2.7K Sep 23 17:57 wp-cron.php
drwxrwxrwx  9 pi       root     4.0K Dec 11 16:20 wp-includes
-rwxrwxrwx  1 pi       root     2.0K Oct 23  2010 wp-links-opml.php
-rwxrwxrwx  1 pi       root     2.4K Oct 26 20:40 wp-load.php
-rwxrwxrwx  1 pi       root      29K Nov 30 13:40 wp-login.php
-rwxrwxrwx  1 pi       root     7.6K Sep 25 06:26 wp-mail.php
-rwxrwxrwx  1 pi       root     9.7K Nov 22 09:52 wp-settings.php
-rwxrwxrwx  1 pi       root      18K Sep 11 13:27 wp-signup.php
-rwxrwxrwx  1 pi       root     3.7K Jan  8  2012 wp-trackback.php
-rwxrwxrwx  1 pi       root     2.7K Sep 11 21:11 xmlrpc.php
share|improve this question
1  
check folder permissions, if you are fine with it include the urls to your website –  Shekhar Jan 7 '13 at 20:20
    
I've checked all permissions again, and even changed them to 777 for the time being to see if that would help. Added URL to post. –  Nysepho Jan 7 '13 at 20:26
    
your link to about me is raspberrypi/?page_id=13 shouldn't it be something like raspberrypi.org/?page_id=13 –  Shekhar Jan 7 '13 at 20:37
    
Strange, that's the hostname, which is what I used to set everything up. I'll try setting it up from the domain instead. –  Nysepho Jan 7 '13 at 20:38
    
It's all working now. I'll write an answer. –  Nysepho Jan 7 '13 at 20:59

1 Answer 1

I'd set up WordPress from my desktop PC using the Raspberry Pi's hostname as the URL. This meant that every URL was http://rapberrypi/<file> instead of the proper URL.

share|improve this answer
1  
congrats, but your current question and the answer is too localized, on SU we try to keep questions that will cater to an issue that many people might face. I would suggest you to explain in detail what the issue was and how to rectify it, or it might be voted to be closed –  Shekhar Jan 7 '13 at 21:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.