Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am on a Power Mac OSX mountain lion. I ssh into an amazon aws ec2 instance. Then I want to ssh into the same aws ec2 instance. When I do any command in one connection it is echoed in the other connection (the app I'm using is Terminal). I'm trying to run a command in one directory and see what happens in another (and occasionally tail) using the other terminal connection. Except I can't because the echoing causes both terminal connections to stay in sync... i.e. one is just a mirror of what the other is doing.

How can I disable this. I tried hitting f9 to get a menu (bottom left of the window indicates f9 should call a menu) but this does nothing.

share|improve this question
add comment

2 Answers

This is because on the instance launched Byobu. You need ssh to a host and not launch Byobu at login like this:

ssh -t remotehost bash

You can also run commands in the background using the screen utility.

share|improve this answer
add comment

Mac new user issue. I didn't realize that on a Mac you have to hit a fn button at the same time as the fn9 button in order to get the function button to work. Who would have thought that Apple would have such insight that you would need two buttons to make a function button labeled as a function button to work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.