Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I do not have Visio 2013 on my PC and downloaded the Visio Viewer and installed without errors both the x86 and x64 versions and rebooted. Still there is no file association to the viewer nor does it look like ActiveX is setup in the browser. Anyone have any guidance on the issue or workarounds?

I'm running Win 7 Enterprise.

share|improve this question
    
Open IE and ensure Tools menu / ActiveX Filtering is not checked, then try right-clicking and running the installer as Admin. –  Karan Jan 8 '13 at 0:39
    
Thanks Karan for the reply. The Active Filtering was not on and I uninstalled and reinstalled by run as administrator and rebooted, again with no results. Also checked gpedit.msc to make sure the Activex Installer Service was all set to Not configured. The .vsdx has no file ext association either. My favorite part of all this is that the windows file association online shows File Type: Unknown (shell.windows.com/fileassoc/0409/xml/redir.asp?EXT=vsdx) –  Mouffette Jan 8 '13 at 5:20
    
Do VSD files have associations? Try renaming the VSDX to VSD. Also, have you tried dragging and dropping the VSD/VSDX on an open IE window? –  Karan Jan 8 '13 at 16:19
    
yes VSD has file association as i have visio2010. when i rename to vsd then i get open error "an error(100) occured during the action open file....its not a visio file or corrupted". dragging and dropping to IE only allows me to save it. I've tried repairing as well but no luck. –  Mouffette Jan 8 '13 at 18:10

3 Answers 3

I'm struggling with this same problem. The only way I could get Visio Viewer 2013 to recognize vsdx files on a machine with Visio 2010 installed was to first uninstall Visio 2010, install Visio Viewer 2013, and reinstall Visio 2010.

share|improve this answer

If you have Visio 2010 installed you may also wish to consider the compatiblity pack recently released: http://www.microsoft.com/en-us/download/details.aspx?id=39640

share|improve this answer

I have worked on this for days, tweaking ActiveX, IE permissions, and I have finally found a solution.

For me the fix was to install Microsoft Visio 2013 Viewer Service Pack 1 (SP1). You can download it from the Microsoft site. http://support.microsoft.com/kb/2817444

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.