Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Raspberry Pi running RaspBMC with a WD MyBook connected using USB. The drive is automatically mounted to /media/My Book. I have created a folder /media/My Book/downloads and I have set Trasmission's download directory to be /media/My Book/downloads.

When I try to download a file, Transmission says

Error: Permission denied (/media/My Book/downloads/The.Simpsons.S24E09.720p.HDTV.X264-DIMENSION [PublicHD]/The.Simpsons.S24E09.720p.HD

ls -la gives me

drwx------ 1 pi       0 Dec 15 16:24 downloads 

So I guess the problem is that transmission runs under different user than pi and cannot write to the folder. However when I execute

chmod -R 777 downloads

the operations succeeds without any error but the permissions do not change, they stay 700 just for the owner.

What am I doing wrong and how can I enabled Transmission to write to that directory? It is a NTFS drive, df -T says

/dev/sda1  fusebulk
share|improve this question
Try chmod -R 777 downloads. – Scott Jan 7 '13 at 21:59
Hey Igor, I am just mentioning this in a comment since it is off topic of your request, but just a nudge as it sounds you're learning a ton! Double check your understanding of system permissions, "777" would be r/w/x for all Owner, Group AND Other (respectively). So the owner maintains "7" permissions (read, write, execute). Wikipedia has a good summary here. – nerdwaller Jan 7 '13 at 21:59
@Scott tried that, it is in my post – Igor Kulman Jan 7 '13 at 22:01
@Igor - The location of -R is important. – nerdwaller Jan 7 '13 at 22:01
You order are arguments in typing the wrong the. – Scott Jan 7 '13 at 22:06
up vote 0 down vote accepted

1.- Check if you have installed the driver "ntfs-3g" to have access privileges to read and write NTFS partition.

2.- Edit the file / etc / fstab / and add the following line, depending on the type of usb disk.

/dev/sdb1 /media/ntfs-3g download default 0 0

3.- Mount USB disk with the command:

$mount / media / download

4.- Run Transmission

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.