Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 2880x1800 display and I'd like to be able to run applications on Windows 7 at 1440x900.

Unfortunately if I create this resolution on NVidia Control Panel the image becomes blurry, because even though 2880x1800 is exactly 4 times the resolution of 1440x900, the driver uses its default scaling algorithm, instead of simply double the pixels. Probably I lose some fps in games because of this unnecessary "complex" scaling process.

Is there a way to substitute the scaling for a pixel-doubling one?

My video card is a GeForce GT 650M.

Update: It's a macbook pro retina, I don't think I can change the monitor settings, can I?

share|improve this question
    
Just an idea. Can you set the monitor to scaling mode and feed it 1440x900? – Hennes Jan 8 '13 at 15:27
    
Cool, I didn't know I could do that! Can I? It's a Macbook. – Roberto Jan 8 '13 at 16:47
    
Not sure if you can on a Macbook. Most mid-level to high-level (IPS) monitors have such an option. However I see no reason for apple to put this in a build-in screen. :( – Hennes Jan 8 '13 at 16:52

This isn't a full answer at all, but I just hate how comments are super short and you can't even put line breaks. >_> I hope it helps regardless.

NVidia might be too "smart" for you. You could try those things.

  • Changing the settings in the Control panel, instead of NVidia. Probably, it's going to just be a redirection and tell the NVidia software to do it, but it's worth a try.

  • Try to set your display so it just doesn't scale anything: if the resolution is smaller than the screen, then make the display small with a lot of black around it. There should be a way to do that, because I have a memory of seeing something like this, but I don't remember how. Perhaps it's somewhere in NVidia's and/or Windows' settings. Then, scale your display with the buttons on your monitor, simply. This should not be a very "smart" solution, as you're not asking your computer to do anything.

  • Keep your display in the higher value (2880 x 1800), then set your game to full screen mode and give it 1440 x 900 in the in-game settings. This should give you an effectively stretched and not-so-pretty, easy on the PC, image. I've done that with a game of mine because my crappy graphics card couldn't handle my new 24-inch monitor over my old 19-inch one in-game. So I just put my old resolution (1280 x 768 instead of 1920 x 1080) and stretched it across the screen, and my FPS were pretty much back to what they were before I changed screens.

share|improve this answer
    
Thank you, I tried the first without success and the third I can't see the difference: I think NVidia drivers applies the scaling in the game the same way when I change the resolution at "Windows environment". About the second, it's a notebook, so I'm not sure I can change monitor settings. – Roberto Jan 8 '13 at 17:08
    
Well then, uhm. It may be that you don't have a choice. Perhaps you'll have to go with this. The only other solution I see is to remove NVidia software and go with Windows' default driver. – Ariane Jan 8 '13 at 22:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .