Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using four input languages: English, Japanese, Chinese and Greek. I'm used to having them on Left ALT+Shift+1, ...+2, ...+3 and ...+4, respectively. But on my Windows 7 computers, Alt+shift+1 and +4 keep resetting themselves after a reboot.

I've also got my internet browser set to Ctrl+Alt+I (Right Alt+I), but this one also disappears after a reboot.

How can I fix this.

share|improve this question
    
What version of Windows 7 are you using exactly? – Ramhound Jan 8 '13 at 15:26
    
Do you reboot properly? As in, letting Windows save your user settings and not just pressing the power button or something? If you really can't find a solution, I suggest just using alt-shift to cycle through them and get the right one. This one won't be going away, eh. – Ariane Jan 8 '13 at 16:36
    
@Ramhound: W7 Home Premium – Jiazzz Jan 9 '13 at 12:20
    
@Ariane: It reboots properly. – Jiazzz Jan 9 '13 at 12:22
    
Are you trying to modify a company company or personal computer? When your setting reset do the languages disappear or simply the configuration of the ALT+SHIFT+NUM resets? – Ramhound Jan 9 '13 at 13:43

I had the same issue with input language hotkeys resetting and managed to work around by deleting the contents of the registry key

HKEY_CURRENT_USER\Control Panel\Input Method\Hot Keys

After rebooting, I reassigned the hotkeys and Windows now seems to remember them.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .