Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a account configured in a Linux system so a user can mount it in a certain mountpoint and access its contents. It is declared in fstab as: /media/box davfs rw,user,noauto 0 0

And the user that mounts the account has the ~/.davfs2/secrets with the following:

/media/box <username> <password>

The user can mount and list the mounted folder without any problem, but it gives us some problems when trying to copy files from to our local machine. I've tried the following with these results:

cat /media/box/example_file.txt => Will output the contents of the file
cp /media/box/example_file.txt /tmp => will give the I/O error
wc -l /media/box/example_file.txt => will give the I/O error as well
touch asd && cp asd /media/box && ls /media/box => lists asd in /media/box

I've tried setting

use_locks 0

in /etc/davfs2/davfs2.conf but it doesn't solve the problem.

Any clue what might be preventing the system to properly access mountpoint?

share|improve this question

You must log in to answer this question.

Browse other questions tagged .