Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Linux Mint 11 Katya. Whenever the system is awakened after hibernating, my Windows partitions do not automatically show on the desktop. I have to click on Computer, select one or more of my Windows partitions by double-clicking on them and then it appears my partitions become mounted because my folder links work again and I can see both partitions on my desktop. Is there any way to auto-mount these upon coming back from hibernate?

EDIT

This is my /etc/fstab file

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=45413e15-c59d-4bde-b3c0-70aac7ca8202 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=b231787d-49ad-4e6f-a038-558391312f68 none            swap    sw              0       0
share|improve this question
    
Sounds like you are using autofs, how are your partitions mounted? Please post the contents of /etc/fstab. –  terdon Jan 8 '13 at 16:56
    
@terdon: See update. –  staticx Jan 9 '13 at 1:55

2 Answers 2

up vote 2 down vote accepted

OK, your problem is that you have not set your windows partitions to be mounted automatically. To do so, each of them will need an entry in /etc/fstab, the file where partition mounting settings are kept :

  1. fstab can use either the UUID or the device name of a partition, I will use the /dev/sdxN names because it is easier to explain that way. The first step is finding out what the device name of each of your windows partitions is. The easiest way would be to mount each of them manually as you describe in your question, then open a terminal and run this command:

    mount
    

    That will list the currently mounted partitions in the format of /dev/sdxN on /mountpoint. Identify your windows partitions.

  2. Add the relevant lines to /etc/fstab (for this example, I am assuming the partitions in question are /dev/sda1 and /dev/sda2, replace these with whatever your partitions are called).

    /dev/sda1   /media/windws1  ntfs    defaults    0   0
    /dev/sda2   /media/windows2 ntfs    defaults    0   0
    

That's it! You can check that everything works ok by running sudo mount -a. They should now be mounted automatically next time you reboot.

share|improve this answer
    
Perfect! I will try this later and report back. This is for a home PC and I am work. Thank you. –  staticx Jan 9 '13 at 14:01
    
Seems to work.. going to test more over the next few days. Thanks again! –  staticx Jan 10 '13 at 2:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.