Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed a new sound card, a Turtle Beach card, and can't seem to get sound out of the optical out. lspci says it is a CM8738 chip. I can get static out the front two channels with the following command but that is it so far (when the test says center, nothing works):

speaker-test -Dplug:iec958 -c 6

When sound does come out those two channels, my reciever says PCM, but when the test says other channels, it says NO AUDIO INPUT. I disable the onboard intel audio from the bios.

aplay -l says:

**** List of PLAYBACK Hardware Devices ****
card 0: CMI8768 [C-Media CMI8768], device 0: CMI8738-MC8 [C-Media PCI DAC/ADC]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CMI8768 [C-Media CMI8768], device 1: CMI8738-MC8 [C-Media PCI 2nd DAC]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CMI8768 [C-Media CMI8768], device 2: CMI8738-MC8 [C-Media PCI IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Currently I have the following switches checked: IEC958 5V IEC958 Output

I also tried: asoundconf set-default-card CMI8738

I don't really know very much about sound trouble shooting, so any help is appreciated. I am using Ubuntu 9.04

Update:
If I uninstall pulse, it works okay for XMBC, but nothing else has sound. Not sure what I need to do with the Ubuntu Config.

Also, my card is: Turtle Beach TBS-3300-01 Montego DDL Sound Card

share|improve this question
    
No sound out of the optical out? Dang. I can't get any light out of my speakers, either... ;) –  Nathan Long Oct 9 '09 at 11:59
    
@GorillaSandwich: you can see 'em can't you? :) –  quack quixote Oct 10 '09 at 15:10
add comment

2 Answers

up vote 1 down vote accepted

Basic troubleshooting steps (taken from the DigitalOut with ALSA page I posted to your earlier question):

  1. Check that the card is found and available (already done! good job!)

  2. Check mixer settings (try TonyUser's suggestion of gnome-volume-control-pulse first, then try running alsamixer and seeing if you need to adjust things there as well).

  3. Try playing back a WAV file: "aplay -D hw:0,2 myfile.wav" or possibly "aplay -D plughw:0,2 myfile.wav". If it works your receiver should indicate it's getting PCM data.

  4. If that doesn't work, look for entries listed as "digital audio playback" in the output of "cat /proc/asound/devices". Note the numbers in brackets ("[0- 2]" should be one of them; that's the one we tried in Step 3 with the "hw:0,2" parameter). If there are other entries, repeat Step 3 with each parameter.

  5. If it still doesn't work, return to Step 2 and play with mixer settings.

  6. Once you get it working, you can grab a DTS WAV file from this link to test that digital pass-through is working on your card -- be sure to substitute in the right hw: numbers that you got to work earlier: "aplay -D hw:0,2 Norrlanda.wav". If it works, your receiver should indicate it's getting DTS data.

share|improve this answer
    
Thanks, going to go through this over the weekend. I got digital pass through and PCM working with xbmc when I uninstalled pulse, so now I just need to get regular sound ( ie wav like you mentioned, or the test sound in Ubuntu's sound settings ) to work... –  Kyle Brandt Oct 9 '09 at 11:41
    
So actually, do I want to try to get this all working with Pulse, or can I live without Pulseaudio? Is it like esd, where if I go with just Alsa, I will only one app can have sound at a time? –  Kyle Brandt Oct 9 '09 at 11:49
    
the steps are important -- follow them and use the "aplay" command and you're guaranteed to find the right output device. you can puzzle out the sound settings GUI later. –  quack quixote Oct 9 '09 at 12:01
    
that was probably ESD on OSS (old sound system), which only allowed one program accessing the soundcard at a time. that's partly why they switched to ALSA, to fix that. if you don't have Pulse installed now, go thru the "aplay" steps with ALSA, and make sure it works there -- ALSA's the lower level anyway; if it doesn't work there Pulse can't help. –  quack quixote Oct 9 '09 at 12:06
    
So in the end, a reboot after removing pulse got everything working. I thought killing pulse and restarting X would be the same as a reboot, but apparently something else is going on... –  Kyle Brandt Oct 13 '09 at 12:55
add comment

I've recommended installing pavucontrol before to deal with PulseAudio input/output issues. But I just found a guide HERE about replacing the default volume control with gnome-volume-control-pulse which may help you out.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.