Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently installed Windows 8 Enterprise edition on my Lenovo Z580 laptop. After I have mounted an ISO image to install Visual Studio 2012 by Hyper-V, my DVD-drive disappeared.

I unmounted and rejected the ISO afterwards and even stopped Hyper-V service.
It's not shown in My Computer or Disk Management or Device Manager.

Do you have any suggestion?

share|improve this question
up vote 3 down vote accepted

Try to run this command from a command prompt with admin rights:

reg.exe add "HKLM\System\CurrentControlSet\Services\atapi\Controller0" /f /v EnumDevice1 /t REG_DWORD /d 0x00000001

Now reboot and see if this fixes it.

share|improve this answer
3  
yes problem solved thank you a lot. can you more explain what just happened please? thank you again – Javad_Amiry Jan 9 '13 at 9:22
1  
by default Win8 only enums IDE devices with are configure as master. This also adds the enum of slave devices. – magicandre1981 Jan 9 '13 at 15:45
    
Thanks brother. It worked! – Shyju May 27 '13 at 2:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .