Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A short while ago, I had my hard drive die on me and at the same time my 1Tb backup drive! I took it back to the guy I bought the PC from and although the backup drive could not be recovered, he managed to get my machine working again by making a minor change in the BIOS which then got it out of that continuous loop it found itself in after multiple BSOD episodes.

Everything seems to be working fine but yesterday when I tried to save something from Google Chrome, I got and insufficient permission problem and when I try to install software, I get an error of 2503.

I have already followed the suggestions here but none of this worked for me.

Any suggestions would be appreciated.

EDIT: This started happening after I tried running a number of tests to get the machine working, including a previous restore point.

share|improve this question
    
I'm also checking these posts. windowssecrets.com/forums/showthread.php/… –  SixfootJames Jan 9 '13 at 8:27
    
Do you get the same issue if you try to save to a different location on your hard drive. Try saving it to the downloads folder, or desktop or My Documents and see if the error perists. –  Dave Jan 9 '13 at 9:32
    
Hi Dave. This happens if I try to install or uninstall anything/anywhere on the PC. –  SixfootJames Jan 9 '13 at 16:24
    
Sorry, did you mean to say install? The post says save from Google although it could be related to my theory and potential fix –  Dave Jan 9 '13 at 16:32
    
Hi Dave. The two it seems are related. I cannot save from Google Chrome to any folder, nor can I install or uninstall software. It's a permission issue, but how and why this would happen I am not sure. I have added an edit above. –  SixfootJames Jan 9 '13 at 17:45

2 Answers 2

I suspect that although you are an administrator (I assume you are), you don't have ownership of the "computer".

Please open Explorer and right click on the C drive and select properties.

In the new Window, select security tab, click advanced.

Now, in here, go the Owner tab. I would assume the owner is not your account. You can click edit and make any user the owner, or it may be better to make the 'TrustedInstaller' the owner. You will need to do this for all subfolders etc and this could take a long time.

I suggest you read up about taking ownership first (actually, if you follow my advice, before changing the ownership there is a link to learn more about it) and then go for it.

share|improve this answer

Things you can try is

  1. Run a system file check sfc /scannow

  2. Check whether there is enough permission for the installer drive/folder

  3. Check Windows Installer service is running

  4. Re register the Windows installer

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.