Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My host is an out-of-the-box Ubuntu 12.10 simply connected to Wifi.

I installed VirtualBox, and then a few Linux and Windows 7 Pro guests on it, all with default VirtualBox options (NAT).
I reboot them every day.

Yesterday all had network access.
PROBLEM: Today all the Windows guests says "No Internet access".

enter image description here

Linux guests still have network.

As an experiment, I created a new guest VM, installed Windows inside. Result: no network.

All Windows and Linux guests are out-of-the-box, I did no network tweaking whatsoever. Below is their VirtualBox-side network configuration just in case:

enter image description here

share|improve this question
add comment

2 Answers

As John Siu tipped me, there is probably something wrong with the DNS server in my network.

The solution was to change the DNS from Obtain DNS server address automatically to Use the following DNS server addresses, and entering Google's DNS service addresses, as seen in this screenshot:

enter image description here

share|improve this answer
    
Nice you can pin point the DNS configuration. –  John Siu Jan 10 '13 at 3:31
    
Just wondering did you make some changes to your LAN dhcp server setup yesterday? Otherwise it should work without this changes. –  John Siu Jan 10 '13 at 4:05
    
@JohnSiu: I did not, but maybe someone else in my company did. Strangely, Windows PC users have not complained about any related problem, as far as I know. –  Nicolas Raoul Jan 10 '13 at 5:07
add comment

Did you try to ping from inside any windows guest?

No Internet access is NOT the same as losing network connection. It properly still have LAN connection, but Window think it cannot reach the internet.

When Windows start it make some internet connection(not sure what), if failed it will show that notification sign. It usually go away once you start browsing the web or make some internet traffic. If you have internet connection, the sign may go away by itself in a few minutes.

share|improve this answer
    
Thanks for the tip! It appears that I can ping Google's IP address, but I can't reach my DNS server... which I suppose is set automatically by DHCP, I did not modify any DNS setting. –  Nicolas Raoul Jan 9 '13 at 15:25
    
(1) Check what dns the VM is using. (2) Double check your dns server is actually working outside the VM. Then check within the VM again. –  John Siu Jan 9 '13 at 15:57
1  
+1 Your tip definitely pointed me in the right direction, now it is working :-) I created a separate answer to detail how I did with a screenshot, though. –  Nicolas Raoul Jan 10 '13 at 3:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.