Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The checkbox to install Hyper-V in Windows 8 Pro is disabled. Hovering over it reveals the message, Hyper-V cannot be installed: Virtualization support is disabled in the firmware. There is a virtualization option in the UEFI settings that was previously disabled, but I enabled it, and then did a cold boot. My processor seems to support the necessary virtualization features, according to the Intel website (VT-x and SLAT). Do I have any chance of getting around this?

share|improve this question

migrated from serverfault.com Jan 9 '13 at 10:38

This question came from our site for professional system and network administrators.

2  
Contact your hardware vendor. –  Michael Hampton Jan 9 '13 at 4:52
    
That's always fun. I'll do that tomorrow. –  Zenexer Jan 9 '13 at 6:11

5 Answers 5

There are a few requirements that must be met to enable Hyper-V on Windows 8. According to this TechNet article, other than SLAT, you must also have 4GB of RAM and the system must be 64-bit. These requirements are listed on the Client Hyper-V page on TechNet.

There is a simple check that you can also run to verify that your system meets the requirements. Open a command prompt and type ‘systeminfo.exe’ (without the quotes) and hit enter. The last section will show four lines:

VM Monitor Mode Extensions:

Virtualization Enabled in Firmware:

Second Level Address Translation:

Data Execution Prevention Available:

These will have either ‘Yes’ or ‘No’ next to them, which should help you to track down the exact issue that is stopping you from enabling Hyper-V on your system.

More information about Hyper-V and other new features in Windows 8 can be found on the Explore page of the Springboard Series on TechNet.

Hope this helps.

share|improve this answer
    
Virtualization Enabled in Firmware read No, even though I had enabled it in my UEFI/BIOS settings. It just wasn't taking effect at first. As @Chaos mentioned, it was likely partially due to Windows' ability to save its kernel state. I described the resolution process in another answer. –  Zenexer Jul 14 at 18:13

There is a blog post on how to set the BIOS settings at http://itproguru.com/expert/2012/07/configure-bios-before-installing-windows-server-2012-and-hyper-v/ it works for 2012 and Windows 8. Windows 8 does require SLAT (Second Level Address Translation) which is a hardware feature. This feature is not needed for Windows Server 2012 unless you enable remote desktop services.

You also have to have virtualization enabled in the Boot Configuration Data; see http://itproguru.com/expert/2011/08/boot2vhd-part-4-bcdedit-is-the-magic-deep-dive-boot-configuration-manager/. If you used a sysprep image to create your machine you must make the bcd changes...

  1. On the computer where you deployed the image, open an administrative command prompt.

  2. At the command prompt, move to the following directory: %Windir%\System32

  3. Type the following command, and then press Enter:

    bcdedit /set {current} hypervisorlaunchtype auto
    

    On Windows 8.1, the command is:

    bcdedit /set hypervisorlaunchtype auto
    
  4. Restart the computer.

share|improve this answer
    
To enable on my previously running machine after the bios change I rebooted a few times and nothing, then I did the Bcdedit step and that sorted it out, so that step is definitely required sometimes. –  Scott Sep 23 '13 at 11:41
    
I'll definitely give this a try if it happens again. I bet I wouldn't run into the problem described in the answer by @Chaos if I did this, since Windows would be aware of the change. –  Zenexer Jul 14 at 18:10
up vote 1 down vote accepted

A few more cold boots seem to have fixed the problem. I guess one cycle wasn't enough.

Update:

The setting seems to reset every time I install major updates/OS upgrades. To fix it, I need to:

  1. Change the setting on my laptop
  2. Let it boot into Windows
  3. Turn off the computer normally (cutting power breaks the process)
  4. Unplug the laptop
  5. Remove the battery
  6. Wait about 30 seconds
  7. Replace battery, plug in, turn on
  8. Repeat 2-3 times until it works
share|improve this answer

I had a similar problem. What usually does the trick is to disable fast boot because it seems to check those kind of settings from the kernel state image.

share|improve this answer
    
That's probably why I had to retry it so many times. –  Zenexer Jul 14 at 18:08

Having just experienced this issue myself today, I think the trick is to restart the computer and not shut down. I had done a few cold reboots with no success and went to disable the fast-boot option where I read the following:

"Turn on fast startup - This helps start your PC faster after shutdown. Restart isn't affected"

I then proceeded to restart the computer instead of shutdown and hey presto, it worked! This could be be coincidence but I think it's likely that fast startup is disabled in the event of a restart.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.