Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my Ubuntu 12.10 machine, I've updated Firefox to version 18 some minutes ago. After that, fonts on sites are too smooth and now it's difficult to read for me.

I found some advices about my problem like that question How do I disable font smoothing/hinting/anti-aliasing on Firefox 4? and read official forums but on my machine there are none of the following items in about:config:

  • gfx.direct2d.disabled
  • gfx.content.azure.enabled

And the addon Anti-Aliasing Tuner is not available for me either.

How should I fix this problem?

share|improve this question
    
Try manually creating the values by going to about:config and right-clicking anywhere blank: New -> Boolean. Make sure you get the spelling correct. Also, try disabling hardware acceleration (Options -> Advanced -> Untick use hardware acceleration when available). Make sure you restart the browser after every change you make to let the changes set in. –  Wk_of_Angmar Jan 9 '13 at 19:51

3 Answers 3

  • Create a boolean setting gfx.direct2d.disabled in about:config
  • Set its value to True

The above worked for me.

share|improve this answer
    
Looks like this doesn't work for text on transparent background, at least in some cases. When the background is visually, say, white but in fact transparent, the text is blurred; when a colour is assigned —be it white or any(?) other— the text has default system-wide anti-aliasing. This didn't happen until Firefox was upgraded from v.17 to 18. –  neithere Jan 11 '13 at 7:51
    
It doesn't work in my case. –  edem Jan 13 '13 at 15:16

Creating ~/.fonts.conf:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font" >
  <edit mode="assign" name="autohint" >
   <bool>false</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="rgba" >
   <const>none</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hinting" >
   <bool>true</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hintstyle" >
   <const>hintslight</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="antialias" >
   <bool>false</bool>
  </edit>
 </match>
</fontconfig>

worked for me

share|improve this answer

Tweak the following preferences on the about:config page

layers.acceleration.force-enabled > true

layers.acceleration.disabled > false

gfx.xrender.enabled > false (this one "may", not sure yet, decrease performance a little but it will give you crisp & clean font rendering)

share|improve this answer
    
You won't believe me but these approaches don't give any effect. –  edem Feb 1 '13 at 23:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.