Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Trying to SSH in to remote computer but still asking for password.

I have a number of computers running SElinux and only one of them is giving me a hard time using ssh without the password.

I did a ssh-copy-id and I can see my key in the .ssh/authorized_keys.

I chmod 700 .ssh and chmod 600 all the files in ./ssh/*

of i do a ssh -v this is my output:

OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to wcmisdlin05 [10.52.208.224] port 22.
debug1: Connection established.
debug1: identity file /home/jsmith/.ssh/identity type -1
debug1: identity file /home/jsmith/.ssh/id_rsa type 1
debug1: identity file /home/jsmith/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
debug1: match: OpenSSH_5.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'wcmisdlin05' is known and matches the RSA host key.
debug1: Found key in /home/jsmith/.ssh/known_hosts:9
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: gssapi-keyex
debug1: No valid Key exchange context
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_501' not found

debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_501' not found

debug1: Unspecified GSS failure.  Minor code may provide more information


debug1: Unspecified GSS failure.  Minor code may provide more information


debug1: Next authentication method: publickey
debug1: Offering public key: /home/jsmith/.ssh/id_rsa
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Trying private key: /home/jsmith/.ssh/identity
debug1: Trying private key: /home/jsmith/.ssh/id_dsa
debug1: Next authentication method: password

Can someone please tell me why its not working on this one remote computer?

share|improve this question
    
Have you compared similar ssh -v output when you connect to one of the other machines? –  Doug Harris Jan 9 '13 at 14:35
    
yes and most of them stop at Authentications that can continue: publickey –  techsjs2012 Jan 9 '13 at 14:41
    
Have you checked if your keys are in correct format? Sometimes you will have to convert your ssh-key to another format. I.e. you have a public key in openSSH format but your server is ssh.com. You can get more information out of the log by adding multiple 'v' (like -vvv). –  fragmentedreality Jan 9 '13 at 14:52
    
Check the permissions on the home folder of the user you're trying to log into. ls -al /home/ –  Rob Jan 10 '13 at 17:04
add comment

1 Answer

The following should have you going:

  • chown -R <your user> .ssh
  • chmod 700 .ssh
  • chmod 600 .ssh/authorized_keys
  • restorecon -r .ssh

Additionally make sure your .ssh/authorized_keys is correct and sshd_config is not messed up (try reverting to original coming with your distro) especially check AuthorizedKeysFile and AuthenticationMethods options. Your ssh log shows that AuthenticationMethods must be correct.

Look at you server's system log to see what error ssh tells. If there is something wrong with permissions of authorized_keys it should be in there. Unfortunately if you are using wrong key it's hard to tell from logs.

share|improve this answer
    
restorecon did it for me, thanks very much. This is what I get for trying to leave selinux enabled! –  miken32 May 20 at 21:21
    
@miken32, good that you keep it on. It's very mature now IMHO.I've never had issues with selinux since years. Of course you need to enable booleans and ports when running not so common configurations like apache httpd as proxy but that's the point of it after all. –  akostadinov May 21 at 11:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.