Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I like to develop in Notepad++, but ever since I installed MS Office 2010, even after setting it as the default editor for all html/php/js files, I still get the XML Editor's icon in the file browser, and not Notepad++'s.

I also would like to get rid of that XML Editor entirely, so if anyone can tell me what to change in Add/Remove programs to wash it off my system, I'd love to hear about it.

share|improve this question
    
Did you try right-clicking an XML file / Open with / Choose default program, then selecting Notepad++ and ensuring the Always use selected program option was checked? –  Karan Jan 9 '13 at 17:01
    
@Karan Yes. It does open with Notepad++, it's just the icon that's not changing. –  DJDavid98 Jan 9 '13 at 17:02
    
Try resetting the ICON using the file Properties selection. –  mdpc Jan 9 '13 at 17:06

2 Answers 2

up vote 2 down vote accepted

If the file association is set correctly and only the icon needs to be changed, you can use something like FileTypesMan to accomplish this.

  1. Select the file type/extension you want to edit from the top pane:

    enter image description here

  2. Next edit the selected file type (via right-click/context menu or F2) and ensure the Default Icon field is set to properly point to Notepad++'s executable (or whichever file contains the icons; perhaps a .DLL):

    enter image description here

  3. Exit FileTypesMan, log off and log back in or reboot as required, then test your changes

Of course you can do all this from the registry as well, but this utility just makes it easier (and likely safer too). :)

Regarding removal of the Office XML Editor, I didn't find a separate entry under Add/Remove Programs for it, neither could I spot it when I chose to modify the Office 2010 installation and Add/Remove Features. Perhaps I somehow missed it. Anyway, no harm in it being there as long as it's no longer associated in any way with the .XML extension, which is what you want.)


Edit: The Notepad++ File Association utility might also be able to help, otherwise I would recommend trying again via the program itself, or reinstalling so that the installer can set all default file associations properly.

share|improve this answer
    
You get a +1, but this will always have to be done every time I want to associate a new file type. I want to either remove it entirely, or change the icon for all future associations, dynamically. –  DJDavid98 Jan 9 '13 at 17:13
    
I don't get it. Why will this have to be done every time? Normally when I change the default program associated with an extension, the icon changes to whatever that program uses. In this case obviously something went wrong and Notepad++ wasn't able to reset the icon. You shouldn't need to go down this route every time; normally the icon should be changed along with the default associated program. –  Karan Jan 9 '13 at 17:16
    
This program you suggested edits the "File Type", not the icon of the bound program. Thus, I assume every file type has to be changed individually. –  DJDavid98 Jan 9 '13 at 17:18
    
Err... Did you see step #2 above? The File Type Icon is part of the File Type Association, just that in this case they happened to get out of sync on your system for XML files. This program allows you to change everything, but you can simply edit the Default Icon field in your case and leave everything else untouched. –  Karan Jan 9 '13 at 17:22
    
If you're still having problems with Notepad++ file associations, I found a specific Notepad++ File Association utility for you, but I've never used it myself. FWIW, the official Notepad++ Wiki article on file associations mentions FileTypesMan as the program of choice to fix possible issues, so no idea why it's not working for you. Perhaps something is overriding the change. It would be easy to confirm in the registry if you know how... –  Karan Jan 9 '13 at 17:34

I had this problem this morning and found this question while searching the web on how to fix it. I tried this FileTypesMan tool which led me to solve it although the actual tool did not help. When I found the TypeName with the bad icon, I right clicked and followed the link to regedit. From there, it showed me a type called Notepad++_file, along with several others named things like Notepad++.cpp, Notepad++.h, etc. Now I don't really know where those other types came from compared to Notepad++_file, but I noticed for some reason Notepad++.c is the type that is actually associated with .c files on my system, as opposed to this catch-all Notepad++_file. And I also noticed a difference between them, there was a subkey under Notepad++_file called extShell, that the others did not have. I deleted this extShell key, rebooted, and it all works now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.