Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have carefully followed the instructions in the first answer, but I still can't get the network adapter to be shared with the host operating system. My symptoms appear to be identical to this question, but a reboot did not fix the issue. Networking works fine for my VMs, and it's connecting to the wireless network, but I cannot get access to the Internet from my host OS.

It appears that this guy is having the same problem, but he hasn't said anything for a few days.

Here is a screenshot of my virtual switch configuration when I have it turned on: Hyper-V virtual switch settings

share|improve this question
up vote 11 down vote accepted

I would recommend against using a wireless connection with Hyper-V, as it can cause no end of issues when trying to connect to networks.

You could try changing your Hyper-V network to an Internal network:

enter image description here

This appears as a new virtual network adapter in your host:

enter image description here

Then depending on your needs, either enable Internet Connection Sharing on your wireless adapter:

enter image description here

or bridge the new internal adapter and your wireless one (ignore that this screenshot shows two virtual networks):

enter image description here

share|improve this answer
    
I'd set this up before, and forgotten about the internal network adapter/sharing option. Thanks for the reminder. – Ryan Jan 9 '13 at 18:53

You have to enable "Allow management operating system to share this network adapter". But it seems that there is a bug. If you create an external network connection with this check mark set then only your guests have internet connection. uncheck this feature, apply settings and than redo.

Check > Apply > uncheck > Apply > Check > Apply. I tried to get this working for several hours. Thanks microsoft for this bug.

Network bridging or sharing internet connection is a very bad idea and not the right solution. It makes sense if you are in a private network at home with only one network adapter, but if you have more than one interface in a business environment then do it right, not with a workaround.

share|improve this answer
    
I can vouch for this fix, i tried everything, then reset it all, added an external switch, then unchecked, hit ok, then rechecked it and hit ok. THEN I added it to the vm network properties and everything worked. thanks steven for posting this! – SelAromDotNet Sep 23 '15 at 6:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .