Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
# mount -t ntfs-3g -o no_def_opts,windows_names,noatime,uid=1000,gid=1000 /dev/disk/by-id/ata-Maxtor_6V250F0_V593GLTG-part1 /mnt/ata-Maxtor_6V250F0_V593GLTG/

# mount
/dev/sda1 on /mnt/ata-Maxtor_6V250F0_V593GLTG type fuseblk (rw,nosuid,nodev,noatime,user_id=0,group_id=0,default_permissions,blksize=4096)

The owner and group are correctly set (according to the ID) when I look at the output of:

ls -la /mnt/ata-Maxtor_6V250F0_V593GLTG

When there is no uid=1000,gid=1000 (first command) there isn't

default_permissions

in the output (second command).

According to the man page of mount.fuse:

default_permissions
          By  default  FUSE  doesn't  check file access permissions, the filesystem is free to implement it's access policy or leave it to the underlying file access
          mechanism (e.g. in case of network filesystems). This option enables permission checking, restricting access based on file mode.  This is option is usually
          useful together with the allow_other mount option.

So it is a little bit confusing, that UID and GID remains 0 (second command OUTPUT), but an another option is set.

I've also noticed that however ntfs-3g is a FUSE filesystem, it is different than the others:

Unprivileged user can not mount NTFS block devices using the external FUSE library. Either mount the volume as root, or rebuild NTFS-3G with integrated FUSE support and make it setuid root. Please see more information at http://tuxera.com/community/ntfs-3g-faq/#unprivileged

Does somebody know the reason of the above "issue"?

Regardless, it is working fine. Just curious.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.