Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I finally figured out the command to disable touchpad in my Fedora 17 using Gnome desktop 3.4.2.: xinput set-prop 13 132 0 (specific to my Thinkpad)

Now where do I put this command, so that it is in effect every time I start the computer? I tried putting it in ~/.xinitrc, but to no effect (the command itself works, when executed in command line, but the file is not executed automatically when I start the PC).

share|improve this question
add comment

3 Answers

Put your command into a script, such as DisableTouchpad.sh then create a folder ~/.config/autostart and put the script in there

http://stackoverflow.com/questions/8247706/start-script-when-gnome-starts-up

share|improve this answer
add comment

Whether ~/.xinitrc is run will depend on your Desktop Environment, ost modern ones do not use it as they do not use xinit. You could try adding it to /.xsession or to the startup scripts in /etc/rc5.d

EDIT: Assuming you are always using Gnome, @Kruug's suggestion is probably better.

share|improve this answer
add comment
up vote 0 down vote accepted

I finally figured it out. From terminal I started gnome-session-properties. This shows "Startup Application Preferences" where in the tab "Startup Programs" I added an item with xinput set-prop 13 132 0 as a value of "Command:" field.

For completenes - how did I find the numbers above? Using xinput list I found the id of my Touchpad (id=11 in my case). And using this id xinput list-props 11 I found the option for enabling/disabling device has number 132, the value 0 meaning disabled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.