Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 PC with TeamViewer installed on it. This computer is always on and has no screen, keyboard and mouse attached to it, only an internet-cable.

I login from my Mac on TeamViewer, create a connection to my Windows 7 PC and the result is an 640x480 screen. The problem is that my Windows 7 PC does not detect any display.

If I check display settings in Win 7 then this happens: enter image description here

I can't select another resolution. How can I choose another resolution?

share|improve this question
    
Did you install the correct graphics drivers? –  ChrisN Jan 10 '13 at 0:04
    
Default drivers of my graphic card are installed. I didn't install any other one. Do I have to? This is my view of Win7 in Teamviewer right now: cl.ly/image/01160D31472I –  Pieter Jan 10 '13 at 0:55
1  
Can you force the resolution using your graphics card drivers? In my nVidia Control Center, I can go to Display-->Change resolution, click on Customize, and click Create Custom Resolution... I don't know if that would work because you don't have any physical displays attached. Your best bet would probably to use Remote desktop - it isn't affected by display size on the remote computer - it uses your local display size. –  ChrisN Jan 10 '13 at 1:28
    
Hi Chris, thanks for your reply. I did try an custom resolution setting but indeed it do not work without a display. So I installed Remote Desktop and now it works fine! –  Pieter Jan 11 '13 at 12:10
2  
I have the same problem with windows 7 (enterprise) laptop. My current workaround is to connect a monitor. Note that I never use the monitor, I just connect it. A decent solution or even a hardware dongle which can fake a connected display would be nice. –  Hennes Apr 20 at 10:28

5 Answers 5

@ChrisN comment is the right answer. I'll post it as an answer to the readers:

In my nVidia Control Center, I can go to Display-->Change resolution, click on Customize, and click Create Custom Resolution: Creating custom resolution

After that, select the checkbox that adds it to the list of resolutions and select in on the main "Change resolution" screen.

share|improve this answer

Try this :

  1. Access Control Panel -> Appearance and Personalization -> Display -> Screen Resolution -> Advanced button.
  2. In the Adapter tab click List All Modes.
  3. If not enough modes are shown, try to uncheck the Hide modes that this monitor cannot display checkbox in the Monitor tab.
  4. Click on a resolution to choose it
  5. Click OK twice.

image

share|improve this answer

If installing the latest graphics driver hasn't helped you, then this might.

It's a tutorial on how to create a dummy VGA plug so your computer thinks you have a monitor connected. However, I haven't tried this out myself so I have no way of knowing it'll work for sure.

I found out about this from a Super User answer here. Let me know if this helps.

share|improve this answer
    
I am not sure if this will work on my laptop, but the idea is beautiful in its simplicity and I will attempt it. –  Hennes Apr 27 at 15:37
    
I don't know why you're facing this problem on a laptop. Is your laptop monitor busted? –  Vinayak Apr 27 at 16:50
    
There are two reasons: The part is practical. I tried leaving the lid slightly open in the first few weeks and my cat kept walking over it, closing the lid. But the main reason is that it annoys me that there was no clean solution for this. There is/should be no need for an open lid or any physical monitor. I can RDP into laptops with any resolution I want. No problems when using that protocol. No problem when using X-windows. But with VNC and teamviewer I am somehow needlessly limited and I am trying to work around that. –  Hennes Apr 27 at 19:53
    
If you wonder why I do not just used RDP: I can't. It is a work laptop and I already asked for a way to RDP to the laptop. I got neither that nor my backup question (which was a VM with a copy of the work software). That leaves me with a physical laptop on which I am allowed to install teamviewer but not RDP. –  Hennes Apr 27 at 19:56
    
@Hennes, I think I still don't fully understand the problem you're facing. I decided to reproduce your problem and I installed TeamViewer as well as RealVNC server on my notebook, set them up for remote access and closed the lid. I connected to the system using my Android phone which has both the VNC and TeamViewer apps installed. I checked the screen resolution and it was still 1366x768 (my notebook's native screen resolution). However, my notebook is running Windows 8. –  Vinayak Apr 28 at 7:33

There is no Screen, so Windows Detects that there is no screen.

all you have to do is connect a monitor to it, you don't have to use it, just connect it.


another option is to purchase a Dummy Dongle, it sounds like there are a few of them out there if you know where to look, another Superuser was able to find this DVI-Dummy it seems pretty expensive to me, but I have never had the need to do something like this before.

another option is to look for people that do stuff like THIS I don't really know what they are talking about with the EDID Dongle, but it sounds like you can make the graphics card think there is something of a certain resolution connected to it.

share|improve this answer

I have 2 Desktops, 3 Laptops, 2 Android Tablets and 1 Android Moto phone. All with Teamviewer. I encountered the "640x480" intermittently, it seems. Sometimes my Remote Display is good, sometimes not. Even logging in to remote displays from different devices gave no solution. You know what I finally realized?.... (This just may be something specific to me-not that I'm special). After updating my Graphics Drivers, the 640x480 (sometimes) corrected itself. Then, using the Graphics Driver Install from Teamviewer, would revert my display back to 640x480. Hmmm.......So now, I keep my Manufacturer Graphics Adapters set for the Card/Monitor on the systems. Been this way for more than 6 months (at one time, I was having such problems, I redid all Passwords and Security Settings, thinking someone may be "listening" to my connections). Silly me.

Anyway....Uninstall Teamviewer GMH / GBH / Or whatever that Graphics Display Driver is, and update your Driver for the Specific Adapter and Monitor attached. If there is no monitor attached, it should still work just basing it off of the Graphics card installed in the system, provided you're able to navigate the whole of the screen to select miscellany.

Hope this helps some of y'all, if not all y'all.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.