Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a disk in a two-disk software RAID-1 for which recently an "offline uncorrectable sector" appeared in the SMART status.

198 Offline_Uncorrectable   0x0030   200   200   000    Old_age   Offline      -       1

This apparently is only a sign of imminent disk failure if it occurs increasingly frequently (and since the drive is mirrored, there is no great risk of real data loss either). At the time, a self test also failed at some point and smartd sent me an email to notify me of this as it of course should do.

However, writing to the damaged sector usually causes the disk to use one of its spare sectors instead which it apparently did because since I dded over the disk, all self-tests ran through just fine. And badblocks also found no reason to complain.

Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
[...]
# 5  Extended offline    Completed without error       00%      5559         -
# 6  Short offline       Completed without error       00%      5540         -
# 7  Short offline       Completed: read failure       90%      5524         63273368

The number of faulty sectors didn't decrease though which it shouldn't, really, since the broken sector's still there, albeit unused. However, smartd continues to send me emails every night:

The following warning/error was logged by the smartd daemon:

Device: /dev/sda [SAT], 1 Offline uncorrectable sectors

This is extremely annoying obviously and numbs my healthy panic reflex to smartd mails.

The disk is a Western Digital WD20EARS and the smartd version is 5.41 2011-06-09 r3365.

share|improve this question
add comment

2 Answers

up vote 7 down vote accepted
+50

Maybe you need -U + / -U 198+ in the config file (the + is significant).

If ´+´ is specified, a report is only printed if the number of sec‐ tors has increased since the last check cycle. Some disks do not reset this attribute when a bad sector is reallocated. See also ´-v 198,increasing´ below.

smartd.conf (5)

share|improve this answer
    
-U 198+ should do it. Nice find! –  Michael Hampton Jan 20 '13 at 17:14
    
Works perfectly fine. Thanks a lot! –  Christian Jan 22 '13 at 15:10
add comment

there are two possibilities where these mails come from. smartd is able to send mails by itself, but it's most likely not configured this way so I assume that these mails are sent by logcheck. If this assumption is wrong you don't have to read any further.

logcheck scans log files and sends mails if it thinks that you should worry about anything that happened to/on your system.

You have the option to write a logcheck ignore rule which tells logcheck to not send messages that match a specific pattern.

You could (under Debian based systems) create a file called "/etc/logcheck/ignore.d.server/smartd_own" with the following content:

^\w{3} [ :0-9]{11} [._[:alnum:]-]+ smartd\[[0-9]+\]: Device: /dev/sda \[SAT\], 1 Offline uncorrectable sectors$

This should filter out the annoying mails but write you again if the uncorrectable sectors counter increases.

share|improve this answer
    
smartd sends the messages directly, unfortunately. It's apparently always an option to change this though. I'll consider this if there should be no other way, so thanks! –  Christian Jan 17 '13 at 9:28
    
Oh darn, anyway you have a workaround now. –  hennr Jan 17 '13 at 9:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.