Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Linux Mint 14 with Cinnamon. Currently Alt + F1 opens the 'Expo' mode, showing all workspaces.

I would simply like to unbind/disable this shortcut. Where can I do this? I have searched through the standard keyboard shortcuts in the Cinnamon settings as well as in gconf-editor, to no avail.

share|improve this question
    
With Cinnamon 2.0.2 on Ubuntu 12.04 the solutions posted so far do not work. In the settings under Keyboard Shortcuts > Cinnamon > Toggle Expo all bindings are "unassigned". In gsettings/gconf-editor I have set all occurrences of "panel-main-menu" to "[]". No value at all exists for "<Alt>F1". What the heck? I have been using this shortcut on each working day in the last ten years many times a day! –  Stephen Friedrich Oct 21 '13 at 15:52

5 Answers 5

To free Alt+F1 run:

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "[]"

To revert back run:

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "['<Alt>F1']"

A logout might be necessary to activate these settings...

I got these from a colleague, whose source was Ask Ubuntu. He adds: "This is for Gnome3 but also applies to Muffin (Cinnamon's window manager) as it is a fork of Mutter (Gnome3's window manager)."

share|improve this answer
    
I prefer this approach, but it fails for linux mint 17 cinnamon. I can execute the command and confirm that the value is changed: /home/kidmose $ gsettings get org.gnome.desktop.wm.keybindings panel-main-menu produces @as [] but keybind is still effective after reboot. Any ideas? –  kidmose Sep 24 at 6:15
    
Fixed! sudo gsettings set org.cinnamon.muffin.keybindings panel-main-menu [] and relogging worked for me. It seems like my issue was that the window manager, the structure in the GSettings or something else changed. –  kidmose Sep 24 at 6:30

Under Linux Mint 16 "Petra" Cinnamon, I had a similar problem. Removing the Keyboard shortcuts under gnome-control-center and cinnamon-control-center had no effect. Solution that worked for me:

  • run dconf-editor
  • navigate to org.cinnamon.muffin.keybindings
  • for panel-main-menu, replace ['<Alt>F1'] with []
  • logout & login

(props to Nick Fortescue @ Superuser and michael-schaller @ github )

share|improve this answer
    
Do you know when I can find Control+F2? I want to remove it too. Thanks. –  Kostanos Jan 16 at 0:18
    
What is CTRL+F2? Did you mean ALT-F2? –  maosmurf Jan 16 at 13:17
    
no, I need to remove CTRL+F2 :) –  Kostanos Jan 16 at 18:42
    
what does CTRL-F2 do for you? –  maosmurf Jan 16 at 19:14
    
It opens the small window on the right with title "Enter a command to launch" –  Kostanos Feb 6 at 0:07

It is possible to do this via gconf-editor.

Look under apps->metacity->global_keybindings, Metacity being the GTK2 Window Manager. There should be an item panel_main_menu; double click to set its value to something other than <Alt>F1 or leave it blank to remove the binding altogether.

(This works on Mint 13 with Cinnamon, I can only assume it'll work on Mint 14 as well.)

share|improve this answer

Above solutions worked for me for some time, but since last system upgrade (Arch linux), the metacity package has been replaced with muffin (if I undersetand correctly..), so if this stopped working for you too, try searching those keybindings inside path: org.cinnamon.muffin.keybindings instead of org.gnome....

share|improve this answer

If you use last cinnamon and first answer does not help, go to

System settings -> keyboard -> keyboard shortcuts -> General -> "Toggle expo"

and disable it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.