Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Some time ago I upgraded from Windows 7 Ultimate to Windows 8 Pro x64. Everything works fine, but my Netgear ReadNAS Duo won't show up anywhere besides in the router control panel. There I can see that it has been given an IP and is running (I used SMB under Windows 7 to connect).

Has anyone experienced something like that and knows how to fix it?

share|improve this question
If you know the IP, can you ping it and does it reply? If so, there is a chance it is the AV (my Kaspersky is a pest in stopping the connection) – Dave Jan 10 '13 at 13:58
Ping works fine without loss – Severin Jan 10 '13 at 13:59
I will try that now... – Severin Jan 10 '13 at 14:01
It doesn't seem to make any difference. – Severin Jan 10 '13 at 14:04
up vote 3 down vote accepted

I have a few ideas, each is separated by a line. Hopefully one of these will work for you.

Since a ping returns, I would suspect you need to type that IP into your browser to access the NAS home page.

From here, you should be able to login and set permissions.

Downgrade to an earlier version, like 4.2.21

For your Readynas and Windows 8 issues see this link

Try to connect by IP and by name (IE, in explorer, type in \NameOfNas or \NameOfNas\Public or \192.168.1.X or \192.168.1.x\Public)

Open up your routers home page and see if both devices are connected (many routers give a graphic image or textual detail what is connected via DHCP).

See if you can access the device from another machine to see where the fault is (it could be with the NAS). If another device can access the device, see if you change permissions for your machine.

It could be the antivirus or anti'ware, so disable all protection and see if the issue persits.

Create a shared folder on another machine and see if your computer can access it to indicate/help prove if the issue is with your machine or not.

You can also try the following command in cmd prompt

net config server /autodisconnect:-1

Others have reported the following registry editor hacks work (only do this if you know what you're doing)

Apparently you need to tell Windows that you want to use the machine as a file server and that it should allocate resources accordingly.

Set the following registry key to ‘1′:

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

After that navigate too the following key:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size and set this registry key to ‘3′:


There is a setting in windows Local Security Policy which is incorrectly set by default for viewing an older communication protocol NAS.

To access said setting go to the control panel in Windows 7, in Category view click on the text "System and Security", then click on the text "Administrative Tools".

Now double click and open "Local Security Policy".

In the Local Security Policy screen on the left navigation tree, expand the "Local Policies --> Security Options" then about 2/3rd's the way down the list you'll see a Policy called "Network Security: LAN Manager authentication level". Double click and change the setting to be "Send LM & NTLM - use NTLMv2 session security if negotiated."

Then just press OK and close all of the open windows and then try again


Type in the IP into explorer without the leading \\


Use the software it came with (if any) to see if it can automatically detect it for you.

share|improve this answer
I can access my files without a problem from Android Jellybean, so the NAS itself works. It seems like windows blocks access even when opening the IP - it doesn't say anything but won't show any options besides a panel called "share", which has been stripped of its content. – Severin Jan 10 '13 at 14:16
No, I can't map it to the IP. I'll try to change permission through a different device now. – Severin Jan 10 '13 at 14:19
It doesn't give me any option to change permissions from withing hte NAS control panel. Is there an option like that inside windows I could try changing? – Severin Jan 10 '13 at 14:23
Can you see all the devices in your routers home page? – Dave Jan 10 '13 at 14:35
@Severin - see my updated answer, one of the links is fo ryour exact set up – Dave Jan 10 '13 at 14:51

To connect to a NAS from Windows 8, Try this.. its been tried on a number of PC's without a problem. Edit the registry key


and set to 0

share|improve this answer
Just wanted to add to winman8 post, this worked for me. It was already 0 but I set it anyways "decimal 0" and it the shares started working after reboot (not sure if it was needed) – user233762 Jun 25 '13 at 23:32

You must log in to answer this question.

protected by Community Jun 26 '13 at 4:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .