Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu with Webmin / VirtualMin

And I started getting this issue with thousands of emails coming from www-data which is Apache.. somehow from a virtual site.

How can I disable this feature. I want site users to use SMTP that is created and avoid using the sendmail or any other tricks that a injected shell or script could give a malicious user access too?

I use postfix but stopped it for now. The queue still build up with postfix disabled.

enter image description here

share|improve this question

Use Apaches mod_status

enable it if it is disabled and temporarily remove disallow all prepending # in front of it. Restart Apache.

go to any site and append www.myvirtualsitedomain.com/site-status

now monitor connections and find the culprate

Thanks to help from Ask Ubuntu

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .