Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have stable version 23.0.1271.97 m and updated to Version 24.0.1312.52 m and the problem still persists.

I had installed a FRESH copy of Windows 7 on a laptop with a fresh install of chrome. No plugins no nothing.

Then to double check I went to my desktop with Windows 8 and same thing. I was surprised.

Is this a chrome bug? In chrome on this site I can't uncheck Free! McAfee Security Scan... option OR the Download now button. It does nothing.

Two different computers, one fresh setup and one long standing computer doing the same thing.

Does anyone know anything about this?

Also happens on the links at the top on

share|improve this question
I've been having a number of crashes and freezes with Chrome related to Flash. You might be experiencing the same problem. I tried disabling the Chrome-installed version of Flash, but it's a crap shoot as to which sites lock up and which don't. – Adrian J. Moreno Jan 10 '13 at 19:51
Nope, disabled and still the same thing. – Tek Jan 10 '13 at 19:53
Could it be that Javascript is disabled? oo' – Ariane Jan 10 '13 at 20:31
On a fresh install of chrome? lol no. – Tek Jan 10 '13 at 20:32
up vote 2 down vote accepted

Found out what it was, I had edited the host file to block some advertisement domains (which is why it didn't happen on several other sites). Weird thing is that Chrome didn't bother to connect me to the localhost loopback it just didn't let me click on anything.

So to the thousands of users that have downloaded the blacklist file to block advertisement/virus domains from

should be aware of this.

share|improve this answer
Chrome extensions that do a similar thing can also be the cause of this. That's what it ended up being for me. – nateirvin May 12 '14 at 16:39

You should disable Native Client Plugins. Type chrome:plugins into the URL bar and disable Native Client.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .