Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a web page that submits form data. Here's the thing, it has about a 100 text inputs fields that accept numeric values. The problem that I am running into is that IIS 7 is returning a 500 error when the form is submitted. So I reduced the number of text fields to 20, and the error went away. It seems IIS wants to limit the request size. I have played around with the maxAllowedContentLength setting in the web.config, but that is not helping at all. Is there any other IIS or .Net Framework setting that I need to change for this to work? Please help. My web.config looks like this at this point:

<?xml version="1.0" encoding="UTF-8"?>

<requestFiltering>

    <requestLimits maxAllowedContentLength="1073741824" />

</requestFiltering>

</security>
    <defaultDocument>
        <files>
            <remove value="index.cfm" />
            <add value="index.cfm" />
        </files>
    </defaultDocument>

</system.webServer>
<system.web>
    <httpRuntime maxRequestLength="2097151" />
</system.web>

share|improve this question

100 form fields should not be a problem.

What does your form element look like? Does it say method=POST.

I suspect that method either wasn't specified or it was method=GET, which could generate an extremely long querystring and cause IIS to return the error it was returning.

share|improve this answer
    
I am using method=POST. My form element looks like this: code <form name="doInv" method="post" action="doInventory.cfm"> code – aseem Jan 11 '13 at 5:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .