Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently working on a website in Python, and I'm using pserve with --reload option that reloads the server every time a change in any of the Python files is made. Meaning every time I save any of the files (and I do that often, subconsciously) I keep getting annoying messages from the firewall asking me for permission to run the server. I tried adding pserve and Python binaries to the firewall allow list, didn't help.

Any ideas how can I fix this?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

I was having the same problem, for me an acceptable solution was to define the localhost IP 127.0.0.1 as the listener bind address in the PasteDeploy configuration file. It was previously (by default, I assume) 0.0.0.0 causing bind to all network interfaces. With the localhost only IP given in the host = 127.0.0.1 parameter, the firewall alert is not triggered.

It seemed that there was no sensible way of adding the python executable to the firewall exceptions list, but in most dev scenarios you wouldn't need to bind to other interfaces anyway.

share|improve this answer
    
Yes, I have got this same idea too, making it localhost only rather than 0.0.0.0 which is open to the internet too, but it hasn't worked for me. Im in osx 10.8.2. –  Jan Netherdrake Jan 27 '13 at 19:52
    
K, I tried this again, and it worked. Seems like I was lazy on my first attempt few weeks ago when I only reloaded rather than killed and restarted the pserve. –  Jan Netherdrake Jan 27 '13 at 20:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.