Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 1TB ext4 formatted hard drive other than the one that Fedora has been installed. It is not mounted on boot time and after boot I need to mount it myself. I just click on file manager, it asks for password and it is mounted. How I can change the settings to mount it on start up of computer?

share|improve this question

You need to edit /etc/fstab to mount it during bootup

Basically, you add a new line similar like this

/dev/sdb1     /data     ext4     defaults     1     1

Change first column to your hard disk device name, 2nd column to path that you want it to mount (make sure you mkdir that directory), and the rest is as is

If you want to mount it now, on command line, type

mount /data

and your mount tools will search /etc/fstab for /data and mount the correct partition

Once rebooted, your Fedora will automount your disk

See more info here:

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .