Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When visiting MS Knowledge base articles many are automatically translated (into Dutch).
I prefer the original English texts so that I don't have to second guess which Dutch terms the translator (human or machine) uses.

I'm using a Dutch Win7 OS with a Dutch Firefox browser.
No language or translation related add-ons are installed.

This SuperUser artice is only about IE.
This forum discussion suggests that it is a website (owner) decision, but is also IE oriented.
I do not want to disable all geolocation info as suggested here, because it's fine when e.g. Google search results are tailored to my location.
This article refers to an unreachable FAQ, searching for 'microsoft translation faq' gives me plenty of info about the MS translation services, except how to disable it!

[Edited to add sep 2014]
I redirected to (and to ::1) in the hosts file but that does not block the translation.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

This is part of the Microsoft website, not Firefox.

They do offer a link to compare the translation to the original, and on that comparison page there is a link to the original text. You can circumvent it immediately by adding /en-us to the web address.

Note that translated pages not always tell you that they are, e.g. in the case of Dutch - but maybe that page was not automatically translated.

share|improve this answer
I (the OP) have taken the liberty of editing your answer because it is simpler. – Jan Doggen Aug 27 '13 at 13:30

If you are willing to change your browser-wide preferred language setting, you can request English articles by default - without using extensions.

Related StackOverflow answer here.

In case that one gets wiped: basically you need to change your language preference in your browser and move English to the top. MSDN and KB articles apparently respect the Accept-Language header sent by the browser.

share|improve this answer

At the end of each page, there's a language switcher, which I suppose is actually "Deutschland (Deutsch)" for you. If you set it to "United States (English)", it will never bother you again.

enter image description here

share|improve this answer
I know you are new to this site, but wanted to make you aware you are posting an answer to a 2-year old question that has an accepted answer already. There is nothing wrong with doing so, just realize it may not be responded to or accepted. – CharlieRB Jul 10 at 17:13
This looks like a new feature that was not there at the time I asked the question – Jan Doggen Jul 10 at 18:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.