Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got an old harddrive (Seagate, 200MB) here which just failed, and I wanted to get an image from it with dd. The hd is recognized as device (f.e. /dev/sdb) but dd does not copy anything from it. Additionally to it I can't select it in parted (just does nothing, no error). I already tried to cat it (cat /dev/sdb), but that does also return nothing. This whole thing is at the moment behaving like /dev/null...someone an idea what I could try next?

Thanks in Advance

dd output:

dd if=/dev/sdb of=/mnt/temp.dat
0+0 records in
0+0 records out
0 bytes copied, 2.05 s, 0.0 MB/s

Edit: dmesg is showing at no point errors.

Edit2: Thanks to everyone for the great suggestions, tried them, but the harddisk is gone.

share|improve this question
up vote 3 down vote accepted

Sometimes dead drives will still show up as the devices, since the connectors are still fine and the board is still fine, but one of the other physical components is broken. You could try placing the platters in another disk or paying for professional recovery, but these are probably both overkill. What was on the drive if you don't mind me asking?

share|improve this answer
More or less private data from a client...nothing important (except for him ;) ). – Bobby Oct 9 '09 at 12:04

I know sounds bizarre, but apparently placing the drive in a freezer and cooling it down (sometimes) fixes it for long enough to pull the data off it, until it warms up at least.

  • Consider this a last resort
  • might work if it's a platter related issue, not if its a faulty component
  • Seal the drive well enough to avoid moisture getting inside
  • grab some ice-cream while your at it

I never tried this, but have known about it for years.

share|improve this answer
+1 good thought. it works because the cold makes the metal contract, which might allow stuck moving parts to become unstuck. this is really 2nd-last-resort -- really-last-resort is opening the drive to swap its platters into another drive. :) – quack quixote Oct 9 '09 at 14:25
+1 for ice cream – Rich Jan 27 '11 at 8:41

Gotta agree with John, that sounds like gone to me too.

Couple of things to check before giving the client the bad news:

  • put it on a different controller -- preferably not the same chipset, but at least get it off the controller it's failing on.
  • keep a hand on it when you boot the machine, and again when you try the dd; if you can't feel the spin-up vibrations, the platters aren't spinning; if you can't feel the slight jerking along the face (parallel to the platters), the heads aren't moving. (might be harder to tell during the dd tho.)
share|improve this answer

Another trick which sometimes works is to heat the disk up to 70 or 80 degrees and cool it down to 32 degrees a couple of times.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.