Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to install Guest Additions I see:

sh ./ 

The headers for the current running kernel were not found. If the following module compilation fails then this could be the reason. The missing package can be probably installed with yum install kernel-devel-2.6.18-194.el5

Building the main Guest Additions module [FAILED]

Trying to install kernel-devel-2.6.18-194.el5 I see:

yum install kernel-devel-2.6.18-194.el5

Setting up Install Process No package kernel-devel-2.6.18-194.el5 available. Nothing to do

What can be done with that?

Host OS is Windows 7 64 bit, Guest OS is RedHat 5.5 64 bit.

share|improve this question
up vote 1 down vote accepted

Try kernel-headers-2.6.18-194.el5.

It worked for me on Debian

Usually yum install kernel-headers picks the correct version by itself

share|improve this answer
+1 , assuming this will install devel kernel packages. which solves the problem. – Lorenzo Von Matterhorn Jan 11 '13 at 15:45
@Znau I simply found that in Debian the devel package comes under the headers name. It just worked for me – usr-local-ΕΨΗΕΛΩΝ Jan 12 '13 at 18:59
i normally just install dkms package and gcc. dkms depends on the devel kernel packages so it works for me. – Lorenzo Von Matterhorn Jan 12 '13 at 19:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.