Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I added a keyboard shortcut to change the keyboard layout as described here.

Reversing it doesn't work though. I can change the language from EN to FA by pressing Right AltCtrl but when I press Right AltCtrl again it doesn't change back from FA to EN.

How can I resolve this problem?

share|improve this question
I only know Windows, but hypotheses are 1. alt-ctrl is not "toggle languages" but "change to EN", and you need to look into those settings, or 2. the FA keyboard layout, whatever it is, doesn't have the alt and/or ctrl keys perform the same actions. – Ariane Jan 11 '13 at 20:57
That is very strange, I use the same proceedure as described in the link you gave and happily cycle between gr,es and en. What version of gnome (you are using gnome right?) are you using? – terdon Jan 11 '13 at 21:06
@terdon (yes, I'm using gnome!) I'm using gnome 3.4.1 – ahmadali shafiee Jan 11 '13 at 21:09
@terdon the left 'Alt' + 'Control' works but right doesn't! I edited the question. – ahmadali shafiee Jan 14 '13 at 9:47
@ahmadalishafiee, ah, that may be because in some layouts the right Alt is called "AltGr" and treated as another key. I would guess this is the case for the FA layout, so when you are using it the combination no longer works because the right Alt is not "Alt" but "AltGr". – terdon Jan 14 '13 at 11:22

You must log in to answer this question.

Browse other questions tagged .