Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been helping my neighbor try to resolve an issue which recently cropped up on his new Apple iMac. He can browse the internet just fine, but when he tries to visit a particular site (http://mbeweb.mbe.com), the browser just reports 'Loading' until it gives up and times out.

The site should show a HTTP Basic Authentication login prompt, but it doesn't, in any browser on that iMac. Other sites that require Basic Authentication work fine.

This happens no matter what browser he uses under Mac OS X (Safari 4, Firefox 3.5, Opera, and iCab) and it seems to be only this site (obviously we haven't tried all of the websites available on the internet). From his same home network, he can access the site from his Windows laptop and I've brought my MacBook Pro over and verified that I can connect as well (as can my iPhone).

To make it even stranger, if he launches VMware Fusion on that iMac and attempts to connect to that site using IE or Firefox under Windows XP, he gets the exact same behavior. Other sites work well in Windows.

This happens for a completely new user as well.

From the Terminal, I can telnet to the site (telnet mbeweb.mbe.com 80) and it connects fine and I can issue "GET /index.html HTTP/1.1" and the web server responds with valid HTML and a 401.2 Unauthorized HTTP Error.

I've tried flushing his cache (dscacheutil -flushcache), rebooting the iMac, clearing the browser caches, cookies, stored logins, etc. The issue seems to be localized to this iMac.

He said that it used to work fine. We've contacted the site administration and they explained some recent changes they've made (switched to SharePoint and all of the old links now redirect to it) but verified that they're able to access the site from both Windows and Mac machines (though they did note they had difficulty using Windows running under a VM).

I'm about ready to back-up his machine and re-image it, but perhaps someone has a better suggestion that I haven't tried yet?

share|improve this question
    
Not that this would solve the problem, but I would try in Fusion to set the network adapter to Bridged mode, get new DHCP settings and try the site again. In NAT mode, it's going to NAT through OS X and use the IP address that has already been looked up. In Bridging mode, it should do it as if it's a separate device. –  emgee Oct 9 '09 at 16:19
    
Just a shot in the dark did you try creating a new user account and seeing if the problem persists? Also are there any entries for the site in the hosts file? /etc/hosts –  Bryan Schuetz Oct 9 '09 at 22:24
    
So do you get the same login prompts we get? As for "and all of the old links now redirect to it" -- so this URL is the new link? If not, what about getting the actual new link? And the browsers in the VMware Fusion instance can browse other sites, right? –  Arjan Oct 12 '09 at 7:00
    
@emgee I tried both Bridged and NAT modes within VMware Fusion, both had the same issue. @Bryan Yes, we tried creating a completely new user as well as using his wife's account on the same machine. All have the same problem. @Arjan I get the same login prompt. My neighbor doesn't get it on his computer (thus the issue). Inside of Fusion he can browse everywhere except for the mbeweb.mbe.com site. –  user13724 Oct 12 '09 at 13:05
    
@Arjan There's no VPN involved. –  user13724 Oct 15 '09 at 13:13
add comment

5 Answers

The 401 error I get when I telnet directly to the IIS server at that site (obviously telnet doesn't know how to handle the authentication)

Sure it does, if the one who is in control of the telnet session knows how to do it. ;-)

Your telnet command should yield something like:

HTTP/1.1 401 Unauthorized
Content-Length: 1656
Content-Type: text/html
Server: Microsoft-IIS/6.0
WWW-Authenticate: Basic realm="mbe.com"
X-Powered-By: ASP.NET
MicrosoftSharePointTeamServices: 12.0.0.6318
Date: Mon, 12 Oct 2009 13:35:38 GMT

The WWW-Authenticate header tells a browser to show the authentication dialog, like in Firefox this would show you:

Authentication Required
A username and password are being requested by http://mbeweb.mbe.com. The site says: "mbe.com".

You can surely test that using telnet as well. First, Base64 encode the string "username:password" (using, of course, the actual username and password; dXNlcm5hbWU6cGFzc3dvcmQ= for this example), and then:

telnet mbeweb.mbe.com 80
GET / HTTP/1.1
Host: mbeweb.mbe.com
Authorization: Basic dXNlcm5hbWU6cGFzc3dvcmQ=
[empty line]

So, the question boils down to: why doesn't your neighbour get any authentication dialog on that computer.

  • Does your neighbour get a login prompt at other sites? (Yes, somewhere in the comments.)

  • Can you confirm that on your neighbour's iMac, your telnet command indeed yields a WWW-Authenticate response?

  • What does the output of the Live HTTP Headers add-on in Firefox give you? (Or, when using the Firebug add-on: the output on the Net tab. Or in Safari or Chrome: WebKit's Resources pane?)

  • Your neighbour is not using some VPN, right?

  • Does mbeweb.mbe.com resolve to IP address 63.145.223.67?

share|improve this answer
add comment

I cannot browse the site either (Safari 4.0.3)

This error is from Internet Information Services on a Microsoft appliance. It's probably because the server won't accept anonymous authentication, and you are using a browser that won't agree on an authentication method.

It's also possible you are using a proxy that cannot maintain Integrated Authentication, and the server continues to deny access.

share|improve this answer
    
Did you see a prompt for a user name and password? –  Arjan Oct 12 '09 at 6:55
    
No, he doesn't get the username/password prompt. All of the browsers just keep reporting 'Loading' until they eventually time out and give up (including those running in the virtual machine). I see the login prompt from my Macs and he can see it from his Windows laptop. Whatever it is, it appears to be localized to that iMac. @tb The 401 error I get when I telnet directly to the IIS server at that site (obviously telnet doesn't know how to handle the authentication). I'll see if he's running a proxy on his iMac which could be the cause, thanks for pointing that out. –  user13724 Oct 12 '09 at 13:08
add comment

Try spoofing another browser in Safari 4. Enable the Develop menu in Preferences if you can't see it on screen, then select UserAgent from the Develop Menu and try one of the Internet Explorer options (or any others until you get one that works).

share|improve this answer
    
The question states if he launches VMware Fusion on that iMac and attempts to connect to that site using IE or Firefox under Windows XP, he gets the exact same behavior so I guess that covers that. –  Arjan Oct 12 '09 at 7:02
    
@Bob Arjan is correct, the issue appears to affect all browsers running on this particular iMac. Spoofing another browser within Safar didn't work. –  user13724 Oct 12 '09 at 13:09
add comment

You mentioned that this is a new machine, but did he migrate an account over from an older one? Might he have installed some aftermarket system augmentations that are no longer working properly?

share|improve this answer
    
No nothing was migrated. I was tired of helping de-gunk his Windows machine so I convinced him to buy a Mac. Unfortunately, this incident has soured him on Macs. I don't believe he's installed any 3rd party software that would interfere (at least he didn't knowingly install it). –  user13724 Oct 15 '09 at 13:16
    
"Knowingly" is the key word here. Asking a user whether or not they've installed anything is pointless when they don't know the definition of the word "install" in the first place. –  Hasaan Chop Oct 18 '09 at 17:33
add comment

This is what I get on Windows (please ignore the LastPass stuff):

image

The site is probably using Basic access authentication, which Safari is supposed to support. I don't know Safari, but there might be a parameter somewhere for this. At worst, you may uninstall and reinstall Safari or otherwise reset all options to the default.

share|improve this answer
    
@harrymc Right, I believe they're using Basic Access Authentication. From Safari (and Firefox) on his iMac I can browse to other sites (which I control) that are using Basic Access Auth and the login dialog appears correctly. There is something specific in the interaction between any browser on this particular iMac and that one website, but I cannot figure out what it is. –  user13724 Oct 12 '09 at 13:11
    
Use a protocol sniffer to compare the site that works with the one that doesn't. Knowing the exact difference might explain the problem. –  harrymc Oct 12 '09 at 13:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.